I tried to set shortcuts on my mac and all existing shortcuts were nuked


#1

I was trying to customize my shortcuts and everything got nuked. All shortcuts were completely wiped out. I tried resetting but that did nothing. I put in shortcuts manually and that worked until I tried to see if reset worked. It did’t and everything was nuked again. I also tried reinstalling but nothing changed. I checked for files in the Library but couldn’t find anything related to SU Make. Any suggestions?


#2

Are you seeing no shortcuts at all, or only the SketchUp defaults (e.g. spacebar for selection tool, o for orbit, etc.)?

Reset All on the preferences->shortcuts panel should eliminate your customizations and restore the defaults. It does not step back to a previous customization, it resets all the way to defaults. If it did something else, there seems to be a problem with your Mac’s preferences management, which will take some deeper digging.


Entity Info Dialogue Box
#3

I haven’t seen this affect shortcuts after a restart, but Mac preferences are cached (since Mountain Lion-ish era) by cfprefsd. You can log out or reboot and retry, or open terminal and type “killall cfprefsd” to kill / restart your userid’s version of cfprefsd.


#4

There are no shortcuts at all. Everything is gone.


#5

I will try this. I’m away from my computer now but will reply when I try.


#6

Barry

Tried it but no joy. Not a single shortcut shows up.

Gerry


#7

I did load Layout and the main short cuts seem to be there.

Gerry


#8

Using ‘Windows’ >> ‘Ruby Console’ in SU menu, you can check if the Shortcuts plist is corrupt using

path = File.expand_path("~/Library/Application Support/SketchUp 2015/SketchUp/Shortcuts.plist")
%x(plutil "#{path}")

It should return your path + OK
post the result if not…
john


#9

Your original shortcuts from us should be located in the Mac App Wrapper:

/Applications/SketchUp 2015/SketchUp.app/Contents/Resources/Shortcuts.plist

As @john_drivenupthewall lists above, they’ll get copied when you launch SketchUp or mod them. But the default ones should always be there unless something really is screwed up on your computer, in which case I’d reinstall.


#10

Barry

I already reinstalled but, again, no joy. I’ll check the plist next. I did not that the large toolbox I installed and the cursor change are still retained.

Gerry


#11

John

The Ruby Console comes up along with the I beam but I can’t input anything. When I type, the I beam just disappears. I’ll try reinstalling again. I’ve been reinstalling and rebooting so much it’s almost like I’m using a PC again. ;o)

Gerry


#12

Barry

You just surpassed my level of incompetence. How do I get to the Mac App Wrapper and what do I look for once I’m there. I reinstalled again and, from what I understand about plist files, it looks like I’ve still got the one I modified originally because the modified cursor and toolbars are still there. Is there an uninstall program that will erase everything so I can start fresh or can I delete files myself (scary) to achieve the same result. Regardless, reinstalling doesn’t seem to be working.

Gerry


#13

I have never needed to reinstall SU in the last 8 years, reset plists is usually enough…

If you ‘select and copy’ the code when Ruby Console opens V should paste it and Return/Enter should run it…

you could also test @Barry’s path the same way…

%x(plutil "/Applications/SketchUp 2015/SketchUp.app/Contents/Resources/Shortcuts.plist")

If the User plist is corrupt there is other ‘Ruby Console’ friendly code to delete it…


#14

John

The problem is that I can’t get Ruby Console to operate. I get the I beam but not cursor so nothing shows up when I type. I tried a copy paste in case it was a white on white situation but that didn’t work. It’s been years since I’ve worked at the terminal level so I’m really not sure what I’m doing anymore. Your help is greatly appreciated.


#15

First up is to get ‘RC’ working, it can really make things easier…

What version of SU and OSX are you on? [edit, found it in your profile]

Ruby Console has two ‘Panes’ the top one is the reply [does not accept input]
but the bottom one does when it is highlighted [I have a modified version so a gif is probably counter productive]…

Click into the bottom on start and see if that works…
john


#16

I’ve just upgraded from SU8 to 15. I’m using OS X Yosemite 10.10.3 on a MacBook Pro.


#17

John

I didn’t realize there were two panes. I didn’t see the second at the bottom of the page. I got an “OK” message when input the command.


#18

that’s good news…

try
%x(open "#{File.expand_path("~/Library/Application Support/SketchUp 2015/SketchUp")}") [edited to expand path…]
and you’ll see where all your User Folders live in v2015…
I drag it to my sidebar to make adding materials/etc easier…
if you want to replace the existing plist with the default you can use the mac command ‘ditto’

%x(ditto "/Applications/SketchUp 2015/SketchUp.app/Contents/Resources/Shortcuts.plist"  "~/Library/Application Support/SketchUp 2015/SketchUp")

good luck


#19

I’m a little slow on this stuff. I don’t understand where to input the text you gave me. I tried Ruby but nothing happened. I tried it as a terminal command and got a syntax error. Also, which sidebar are you talking about? I got a mac to get away for diddling around with terminal commands…but I should have known better I guess.


#20

input anything with %x() in Ruby Console and it avoid doing it in ‘Terminal.app’, where you would need to omit that bit of the code to avoid errors, i.e. RC >> %x(echo "hello") Terminal >> echo "hello"

for the ‘open’ one I forgot to expand the path [sorry]

%x(open "#{File.expand_path("~/Library/Application Support/SketchUp 2015/SketchUp")}") 

for the ‘ditto’ one If you delete the user plist first, you will ‘see’ it’s remade, if you don’t it is overwritten and you will only notice the difference in SU when using shortcuts…

john