SketchUp 2016 – Oddities, Surprises, Or Bugs? (RE: Keyboard Shortcuts)


#1

Hi,

I just managed to erase all of the default keyboard shortcuts by pressing the ‘Reset All’ button.

I never used this button before so maybe that’s what it actually does, but I would have expected it to restore the default KB Shortcuts, rather than erase them,… so I figured I’d mention it for whoever is tracking this stuff.


Keyboard commands disappeared
#2

Thanks for the report Jim. Are you on a windows machine or a mac?

I do see this issue on my mac but It seems that restarting brought back my custom shortcuts. Let me know if you see the same

Cheers!
~Bryce

Note to SU team issue filed as SU-33096


#3

Hi Bryce,

I’m on a Mac, running OS X 10.10.5

I did try to restart SketchUp, and even did a reboot on my computer, but neither approach worked.

After that I figured I might as well try to reinstall SketchUp thinking that that would fix it, but that didn’t work either.

I did find a solution by deleting the shortcuts.plist file. . . . When I did the reinstall I just ran the installer again and selected the replace existing files button. Maybe in my case the plist file got corrupted (?), and I guess that file doesn’t get overwritten with a new SU install. I originally wanted to delete all of the SU application files before I ran the new Install, but there was confusion as to which files belonged to SU 2016, and which belonged to SU 2015, … and I didn’t want to loose any of the 2015 files just yet.


#5

Hi Jim

This is a valid issue. If you reset your shortcuts but don’t add any new ones, they will come back with a restart. If you add new shortcuts all the previous shortcuts will be lost. We have a bug logged for this.

The fix in the mean time is to delete the shortcuts.plist file under Library -> Application Support -> SketchUp 2016 -> SketchUp. This will reset defaults and they you can add your own.

We also realize that the process of saving and transferring shortcuts from one machine to another or one version to the next is a total pain. So we have several feature requests logged to help improve things.

~Bryce


#6

Hello,

I’m running Sketchup 2016 on Linux under Wine. Sketchup 2015 runs fine with keyboard shortcuts, but 2016 does not seem to recognize any keyboard strokes. Not only the normal shortcuts for tools, but also Ctrl-C, Ctrl-V and Del key are not registered. I’ve tried the “Reset all” button, but to no avail. Sketchup 2015 still works well.

Edit:

  • When using the “draw text labels” tool, I can type! So I do have a keyboard, but strokes are not registered as shortcuts. Even something as S for Scaling does not work.
  • Using Shift to extend selections does work
  • I tried exporting 2015 settings and reimporting in 2016, this did not work
  • When I look at the Edit/Delete shortcut in the preferences, it is set to Delete by default. When removing that key, and then trying to add it again, the Del key is correctly recognized as Delete in the Add Shortcut box, but when I press the + , I get a popup saying “Key cannot be used as shortcut”. When assigning D to Edit/Delete it is accepted, but not doing anything in the editor

As shortcuts.plist is a Mac thing, I wouldn’t know how to resolve this issue on my system.

Any suggestion what I could do?