Cannot Assign/Reset Shortcuts

Good day,

I’m having issues trying to assign new key commands to certain functions in Sketchup/Preferences/Shortcuts. Sketchup will not recognize ‘Shift’ or ‘Command’. I’ve tried ‘Reset All’, but the button does nothing. I’ve also tried restarting, but to no avail.

As I was researching, an older post suggested I check to see if the Shortcuts plist is corrupt. This is the result:

" > path = File.expand_path("~/Library/Application Support/SketchUp 2015/SketchUp/Shortcuts.plist")
%x(plutil “#{path}”)
/Users/markbeattie/Library/Application Support/SketchUp 2015/SketchUp/Shortcuts.plist: file does not exist or is not readable or is not a regular file (Error Domain=NSCocoaErrorDomain Code=260 “The file “Shortcuts.plist” couldn’t be opened because there is no such file.” UserInfo={NSFilePath=/Users/markbeattie/Library/Application Support/SketchUp 2015/SketchUp/Shortcuts.plist, NSUnderlyingError=0x7fd59940b8f0 {Error Domain=NSPOSIXErrorDomain Code=2 “No such file or directory”}}) "

I’m using:

Sketchup Pro 2019 Version 19.1.173
Late-2013 iMac
NVIDIA GeForce GTX 775M 2048 MB

Thanks in advance,

Mark

A couple of starting points:

  • If you are running SketchUp Pro 2019, why are you looking for the 2015 plist file? Unless SketchUp 2015 is still installed on your Mac, that file won’t exist.

  • Shortcuts (and various other preferences) were changed as of SketchUp 2018 to use a new .json file instead of the old .plist:

/Users/<yourid>/Library/Application Support/SketchUp <version>/SketchUp/SharedPreferences.json
  • On Mac command-key chords have never been allowed as user-defined shortcuts because they are pre-empted by the OS or by ones compiled into the app’s menus, neither of which can be reassigned by users.

That said, there should be no problem assigning shortcuts involving the shift key provided they don’t also involve command. I have several such set on my Mac. And it is not at all normal to have permission issues on Mac because it automatically requires a user password during install (unlike Windows). You could try trashing the file mentioned above to see if it has somehow become corrupted (SketchUp will regenerate it with default values next time it is run).

Thanks, Steve!

Deleting the .json file did the trick.

Mark

This topic was automatically closed after 186 days. New replies are no longer allowed.