Shadows not working

Hi. Some opjects are not casting shadows - will Sketchup not cast shadows on objects colored with a texture (not a placed image)? Thanks

Select the objects and make sure the boxes are checked for cast and receive shadows in the entity info window.

You can deactivate it (entity info window -> cast shadow checkbox) and it depends on the transparency of the used color. But it’s hard to find the reason without an image or the model…

@Cotty beat me to it…
But since I already typed it…

The Shadow settings affect how shadows are shown - e.g. on faces, on ground,
Things which have their ‘cast-shadows’ behavior unchecked [Entity Info] do not cast shadows.
Faces assigned materials which have an opacity below 70% cast no shadows.
Materials using PNG files etc as textures also cast no shadows unless >70% opacity.
Note that some textured materials on faces - like PNG-based ones - do not ‘receive’ shadows - even if they are set to ‘receive-shadows’…

1 Like

Best Practice = keep Entity Info open as you model.
Entity Info Dialog — SketchUp Help

1 Like

Thanks all. Everything’s good now.

Note that some textured materials on faces - like PNG-based ones - do not ‘receive’ shadows - even if they are set to ‘receive-shadows’…

Thanks so much for this tip! I couldn’t get shadows to display on a face no matter what settings I tried, but this was the trick. I converted my texture to a JPG (since it didn’t require any transparency), updated the material to use the JPG and then shadows immediately showed up. Thanks again!