Shadows not working in model


#1

Hello,

I’m using SketchUp 2014 and am trying to work with shadows for the first time.

The model is geo-located and I have ticked ‘Use sun for shading’

I’ve had a look at this forum post and can confirm that my objects (solar panel) are checked for cast and receive shadows.

Another reply in this thread talks about opacity of object materials, I’m not sure how to check that, can someone explain how I would check that or would it be easier if I uploaded a copy of the solar panel component?

Thanks

VW


#2

“Use sun for shading” is mainly intended for when shadows are turned off: it imparts the kind of high contrast between faces as when they’re sitting in the sun, but without the shadow. It’s good for interior scenes.

To make shadows work, click the button that doesn’t look like a button just to the left of the time zone in the Shadows dialog. You can also click its twin to the left of the month scale on the Shadows toolbar.

When shadows are on, you don’t need “Use sun for shading,” because you’re already getting it, along with shadows.

-Gully


#3

@Gully,

Thanks for the heads up, that button is a little bit too subtle.

I gather from the fact that you knew about this feature that you have used shadows within SketchUp. Now that I can turn shadows on, the results are not what I expected.

My understanding is that maximum shading should occur on the summer solstice and I have some look-up tables that I expected my SketchUp model to be fairly consistent with, but the shading as per SketchUp seems to be less than the lookup tables predict (which could of course be due to a misunderstanding on my part somewhere).

Have you found the shading estimates in SketchUp to be accurate?

VW


#4

Actually, @vw1, I’m more a mechanical design guy than an architect, so I rarely use the shadow feature, and then just to give the appearance of a typical shadow, not to simulate actual shadows at a specific location. I happen to be familiar with the shadow controls from playing around with them and from following discussions in this group. I know, though, that other users have made careful comparisons between SU’s shadows and their real life counterparts. Someone like that should be along any time now.

-Gully


#5

That is, whenever someone is finally able to login to the forum.


Hi @vw1,

The Sun reaches its highest altitude at the Summer Solstice and its lowest altitude at the Winter Solstice.
http://en.wikipedia.org/wiki/Summer_solstice

Quite so.
Here’s an example:


#6

OK thanks for the feedback. I’ll go back through all my calculations and see if I can figure out why in my case the shadow projections in SketchUp are different to what I expected.


#7

To display shadows in SU that accurately portray the real world you need to verify these model settings:

• Geographic Orientation — Relationship of True North to the model.
• Geographic Location — Latitude and Longitude
• Time — Year, Month, Day, Hour and Minute
• UTC Offset — The difference between local time and the Coordinated Universal Time standard.

• Are you using SU Pro or the free version, SketchUp Make?

• How did you go about geo-locating the model; Add Location or Set Manual Location?


#8

The model is Geo-Located correctly (via Add Location), if I look at the GeoLocation in Model Info the details are as per Google Earth.

I have entered the UTC Offset (+10:00) for Sydney.

SU Pro 2014.

My expectation was that at summer solstice, the shadow from one row of solar panels should be quite close to the next row, but that is not what SU is showing.

But I think the next step is for me to review the model and my calculations to see if I have made an error somewhere.


#9

Is it necessary to have the GE terrain in the model?


Current local time in Sydney is UTC+11
Daylight Saving Time began on October 5


#10

In Sketchup 13 the Shadows are exactly right, I had noticed a few issues with Shadows in 14 . As I have not had the time to explore further I had been back saving to Sketchup 13 to do shadow diagrams. Now 15 is out it appears as the problem is solved, (do yourself a favour and get Sketchup pro 15 layout is fantastic :sunglasses: ). A tip for Australians in NSW is to use Google maps inside Sketchup and download the location you are looking for then go to https://maps.six.nsw.gov.au/ and take a screen shot of the same and overlay it . This way you will have an up to date map.
Good luck.


#11

In what way where there “issues” with shadows in SU14?


#12

Hi,

Well I guess I should try either SU 13 or 15, but I have made some progress with SU14.

In my model, using SU14, maximum shading occurs on the winter solstice and the model is consistent with what the tables were predicting.

I think this makes sense too, because with winter solstice this is when the sun is at its lowest altitude angle, which in the case of the solar panels is when the shadow from the solar panels will be at its greatest.


#13

What reference tables are you referring to?

Again, why do you find it necessary to have the GE terrain in the model?
Be aware true north is no longer aligned with the default +y (solid green) axis when you geo-locate a model via the Add Location feature.

Window > Model Info > Geo-location > Set Manual Location offers a more straightforward approach, especially when one visits the Extension Warehouse and installs the full compliment of SketchUp Pro Solar North Tools The easiest way to do that is from within SU. Window > Extension Warehouse

More on correct shadows in SU … Here at the SketchUp Sage Site


#14

I noticed it on a couple of concepts we did and the shadows were just not
working the way they should have. To be honest time was a factor and to
save any confusion or uncertainty it was easier to go with the one I knew
was correct through experience. It appeared as though the orientation was
180 degree the wrong way when adding a location in the southern hemisphere.
The removal of the north point axis in 14 was also a factor. I will go back
and have a play and see if I can replicate the issue. I am not sure what
changed, selecting a map location and importing into 14 is a lot slower
than it was in 13. Anyone else experience this?

Kind Regards,

Andrew Dwight

Business Development Manager

O: 02 9679-2429

M: 0413074766

E: andrew http://goog_2026905085@rubysketch.com

W: www.RubySketch.com http://www.rubysketch.com

W: www.PlusSpec.com

[image: See RubySketch] http://www.rubysketch.com
http://www.plusspec.com

Specification Tools & Product for Architects, Designers, Builders & Product
Manufacturers.
Design & Construction Software Development & Implementation
PlusSpec https://www.plusspec.com/ - The Simply Insightful Design &
Estimating Tool for our industry…

CONFIDENTIAL: This email and any attachments may be confidential, legally
privileged and/or subject to copyright. If you are not the intended
recipient, you must not disclose or use the information contained in this
e-mail. If you have received this email in error, please notify RubySketch
info@rubysketch.com Ltd immediately and delete the email and all copies.


#15

I have a Tech Bulletin that specifies the spacing required between a row of solar panels such that there will be no shading of the row during certain hours during the day. Having modeled the solar panel spacing as per the Tech Bulletin I wanted to confirm the shading prediction if I could.

I needed the roof area so that I could trace the roof footprint.


#16

@vw1
The accuracy of a shadow study in SU is contingent upon the accuracy of the data used to build the model and geo-locate it. Tracing oblique GE imagery to create structures is inherently inaccurate.

Apparently your goal is to compare what you’ve created in SU to what your tech bulletin tells you.
Either one or both could be in error.
How would you know, unless you build an accurate model and hold both the model and tech bulletin against reliable third party data?

The model and data sources provided in the aforementioned topic demonstrate how.


#17

hi

is there a way to understand how and whether GE casts and receives shadows? In my model, I see GE terrain is shaded, but shadows from buildings are flat and do not conform to the terrain. Moreover, terrain below the 0,0,0 point does not receive shadows - flat or otherwise. Moving the entire model above the 0,0,0 point (unlocking the terrain) results in nothing receiving or casting shadows… not even building parts on each other.

I tried exploding the terrain, intersecting it with the model, … to no avail.

Any thoughts?


#18

In the shadow settings dialog, untick ‘on ground’.


#19

VW1,
I used to work for a solar company in Minneapolis, MN. I used shadows extensively combined with a paid aerial photography subscription and google earth for geo-location. I have found that the shadows are pretty dead on. after building an array I could go out to a site and measure any shadows on the panels and then go back to the model and replicate the time and date. it would usually be within an inch of where they should be.

Hope that helps.


#20

You need to set the Geographical location on your model.