Shadow not casting

Hello SketchUp Community,

I am trying to design our next house and my Shadows doesn’t cast on surface. I can see the walls brightness changing as I move time but I do not see dark/light area changing.

I am not sure what is wrong with my model.

I checked:

  • Geo location (South of Ontario Canada)
  • Material applied to the wall is stucco with opacity of 100% beside window glass
  • Layer0 is active

I have Make 2017.

What am I doing wrong?

Can you share the .skp file so we can see exactly what you have set up?

In your screenshots you haven’t turned on shadows. Try clicking on the Shadow button in the top left of the Shadows panel.

I would also suggest setting the Light slider a bit more to the left. Setting it to 100 can be problematic.

That is a quick reply! My file is over 350 MB. Not sure I can upload it here. Unless I can upload it somewhere else

I’ve been waiting for you to post your question for an hour! :crazy_face: :smiley:

350Mb seems excessive for that. First, go to Window>Model Info>Statistics and click Purge Unused. See if that reduces the file size. Then upload it to Drop Box and share the link.

Perfect. Will do that. I upload a bunch of furniture, our vehicles and so on. I can purge that for sure.

I have to do some errands, but I will work on that on my way back. I wasn’t expecting you were waiting for my question… :slight_smile:

If you were collecting components from the 3D Warehouse that you later decided not to use, they are likely still in your file along with the materials that came with them. Those can cause file bloat so it’s a good idea to purge them.

Some people call me psychic. Some people call me other things. :smiley:

You should also beware that many items in the 3DWarehouse are seriously over-detailed for use as decorative elements in a larger model. Always download them to a blank model and examine them for excess before putting them into your real model.

For shadows to appear you need both to turn them on and choose appropriate slider values, as @DaveR wrote, you also need to check entity info for individual entities to see whether they are set to cast and receive shadows.

House lean.skp (10.0 MB)

Here you go, I purge the model and remove all the warehouse items. House still missing a lot of sutff but I am trying to get the shadow workin so I can see where the sun will end up in winter and summer.

Thanks!

I turned on Shadows in the Shadows panel and they appear for me. I see you had Use Sun for Shading enabled but you hadn’t turned on shadows.
Screenshot - 10_3_2020 , 10_57_10 AM

On a slightly different topic, you would probably find it useful to learn about using groups and components and the proper use of layers. All of your model except the doors is loose geometry and you’ve got layers assigned to edges and faces which shouldn’t be the case.
Screenshot - 10_3_2020 , 11_02_10 AM

DaveR,

Awesome. I feel such an idiot for not seeing this little button.

This is my first model and I need to learn to construct it better. Say more about the loose geometry and layers assign to edges and faces.

I was trying to have layers so I can remove the roof and look inside if I wanted or remove walls, etc.

Are you saying that all walls, edges, etc should be on layers0?

Can I fix it or I have to start over?

All edges and faces should have Layer 0 assigned to them. (Nothing is put on a layer in SketchUp and with SU2020, the term has been changed to “Tag”.) You need to be making groups or components to contain the geometry and provide separation. So you would model the walls of the house, select the geometry and create a group or component called Walls. Then you can give that component/group the Walls layer. Repeat for the roof so the roof remains separate from the walls. Then you can turn off visibility for the Roof layer to look inside.

You model could be fixed but it would take a lot of time to make sure you get things grouped correctly.

It would be a good idea to go through the SketchUp Fundamentals at learn.sketchup.com

You should also make it a practice to stay on top of correct face orientation. There should be no exposed blue back faces. As nice as it is to apply materials to your model, it’s best to hold off until you make sure the model is built correctly or you will just wind up creating more work for yourself.