Send to Layout not working in 2017


#1

Had SU2013 and just upgraded to SU2017 version 17.1.173. ‘Send To Layout’ is greyed out and not functional. I haven’t changed any file names or anything. All I did was upgrade to 2017 and now it’s greyed out and not functioning. I still have SU2013 (Not open) on my computer and don’t want to delete it until I know 2017 works. MacOs Sierra 10.12.2. Thanks!


#2

Sierra security feature. Please search the forums, this has been answered before.


#3

Thanks, but i’ve searched and see the topic but don’t understand what i’m supposed to do to fix it. If it’s been answered before, I have yet to see someone say this is the problem and this is the fix. I appreciate the “look it up” advice, but the reason I posted is because i’m looking for an answer.


#4

#5

I have no idea what that means. What am I supposed to do with that?


#6

Can you run LayOut normally? That is, can you click the icon and run LayOut 2017?


#7
  1. Open /Applications/Utilities/Terminal.app
  2. Paste this in and hit enter for 2016, or replace version as appropriate:

xattr -d com.apple.quarantine /Applications/SketchUp\ 2016/


#8

Pasted into Terminal. Said there was no such xattr. Screenshot below:


#9

Yes I can run layout normally by clicking on the icon. Just can’t get there through sketchup ‘send to layout’.


#10

yes I can run it normally by clicking on the icon. I just can’t get there
while in sketchup using the ‘send to layout’ option


#11

Are you launching from /Applications/SketchUp 2017/SketchUp.app?

Oops, typo: no slash on the end:

xattr -d com.apple.quarantine /Applications/SketchUp\ 2017


#12

So did this work? Here’s what’s going on: in Sierra, Apple will quarantine drag-installer apps depending on a few conditions. We discovered in beta that when we weren’t signed properly, Apple would copy SketchUp and launch from /var/folders/… , a random location, which was a solution to a potential dylib attack on Macs. This meant that LayOut lost it’s directory location relative to SketchUp, and hence the menu item was disabled. Do you have the 17.1.173 official version of SketchUp? It shouldn’t be doing this. The (xattr) Extended Attribute deletion of this quarantine was what I was trying to fix for you, and given silence, I’ll assume it’s now working.


#13

Sorry for delay in responding. It still wasn’t working for me following
what you wanted me to do. So I was out in the field today and I had my
coworker who was helping me yesterday keep trying. When I got back, he
needed my password to finish what he was trying to do(he was following
another SU thread instructions) and it worked. When I asked how he did it
he said he wasn’t completely sure. I didn’t have time today, but he said
he’ll go back and figure it out and I’ll post it. He said what you wanted
and what he did were close he just couldn’t explain it to me at the moment.
I knew you guys want to know what the fix was so I want it to be clear to
everyone first before I post it works. It’s pretty obvious I’m not that
computer savy so I’ll have my co-worker on it tomorrow. I really appreciate
the help.
Mike


#14

So here’s how it went down. In the pic you can see we were trying your
suggestion with no luck finding the file. In the other forum it said to use
everything from “Sudo to the semi colon”. Pasted that in and it popped up
asking for a password. I entered the wrong password twice before the
correct one, and it worked.


#15

So I’m now following the conversation here now because I"ve been having the same issue for SU 2015.

I’m getting this from terminal

Last login: Fri Jan 13 13:21:56 on ttys000
Miless-iMac:~ milesmayne$ xattr -d com.apple.quarantine /Applications/SketchUp\ 2015
xattr: /Applications/SketchUp 2015: No such xattr: com.apple.quarantine
Miless-iMac:~ milesmayne$

Did I do it right?


#16

Did you see the email before this that I sent? If you look at the picture
that goes along with it, I was trying to do what you were doing and it
wasn’t working for me. If you look at the line that starts with sudo and
ends in a semi-colon. I inserted that and hit enter and it asked for my
password. When I finally put the correct password in, it worked. I’m gonna
attach the pic again.


#17

Yea, @DirtyJerk’s method was to recursively do this and do it as sudo. As I mentioned in Send to Layout not working - Help please! I didn’t have to do that, but YMMV.

Try thowing “sudo” in front of it, as

sudo xattr -d com.apple.quarantine /Applications/SketchUp\ 2015


#18

I did as you say Barry and get

xattr: /Applications/SketchUp 2015: No such xattr: com.apple.quarantine
Miless-iMac:~ milesmayne$

Still no send to LO

It did ask for my password and was not rejected


#19

i had to restart everything before it worked


#20

All went right in terminal entered password and seem to to go right, quit SU and LO and restarted Mac.
Still no “send to LayOut” capability.
Also if I open a .skp file and right click “open with” I have 2 choices for SU and LO


Pro 2017, can't send my sketch to lay out