Send to Layout is greyed out / not working (SketchUp 2018 + High Sierra)

sketchup
layout
mac
2018
mac_pro

#1

Hi everyone,

I’ve read lots of threads before and usually I manage to work things out but now i’m still clueless.
In sketchup 2018 the option ‘send to layout’ is greyed out / not working. I’ve re-installed it after fully deleting everything left in my libraries & support files, checked everything (i think) and also tried entering the sudo-solution in terminal as well as the re-name option. All not working.

So i was wondering if there is any ‘new’ -2018- input on how its possible that ‘send to layout’ is grey and not working… Is there maybe something very easy goin on which i’m not aware of? Or maybe mac+SketchUp2018 has some troubles? Or Sketchup2018+High Sierra? Is there another new security issue i haven’t heard of?

Hope anyone can help me with this one. Thanks.

Manon


#2

Have you entered your SU 2018 license information to register SketchUp 2018 Pro?


#3

for sending to LO the SU model needs to be saved as a SKP document first.


#4

also, have you opened v18 LayOut.app directly from Finder, at least once…

it may have a download flag that requires R-Click >> Open on first run…

john


#5

If you mean, going to my finder - applications - sketchup2018 - layout — and then right click open - - ?
I just tried that and after that i did the same with sketchup… didnt work so far


#6

I know :slight_smile: i did… (I even made the .extension visible to be sure)


#7

yes i believe so


#8

It’s easy enough to check. Why don’t you do it to make sure?


#9

haha no i mean i did


#10

I’m having the exact same problem in PRO except I’m running Sierra. Been doing this for a month or so. Watching this thread. Send to layout is greyed even after save and even if layout is open.


#11

Let me know if you have any new solutions! I’ll send a post as well if i find something but for the moment I still have no clue…


#12

You did drag the file to /Applications on install, correct? Mac security will launch programs that it hasn’t trusted yet by copying them to /var/folders/ some random place. This thread:

Except change to to your version instead of 2016.


#13

Yes i’ve tried that (also by changing 2016 into my version \ 2018/
I’ve tried that with ‘sudo’ as well…
Would it be possible that there is some new quarantaine-apple-mission floating around in 2018 or High Sierra? Is anyone familiar with discovering such new security blocks?
I just think its strange that everything else works fine -so far-, just that little internal jump from SU to Layout… Sounds like it should be only some minor fence somehow, easy to find


#14

well, you can tell by opening terminal and doing ls -al to see if special bits are set.

You can also launch SketchUp and see where it’s launched from. If you’re not a bash shell expert in terminal (ps auxwww | grep SketchUp), then open /Applications/Utilities/Activity Monitor.app, and see where it’s launched from. If it’s /var/folders/blah, somethings up.


#15

hi guys
thanks for your time helping out btw.
I had the same problem as Mosesses - and like him couldn’t resolve the issue. And - I’m a bit worried about tinkering with stuff esp activity monitors, etc…
However, if I save my model (skp file) I then go right click and ‘open with’ and select Layout and this seems to work…
hope that makes sense
Eamon


#16

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.