Selection Tool process is slow, unbearably slow

update
windows10
kb4013429
kb4013418
kb4015438

#61

I have two confirmed cases of this KB causing the performance issue.


Selection Tool Slow Process with Pro 2017 and Windows 7
#62

I fixed this issue a couple of days ago with a windows suggested update (KB4015438) and obligatory restart. But it is back now. Nothing more in my update history. Are we still waiting for a windows fix to their problematic KB4013249 ?


#63

Most likely.


#64

Lol, I thought I had the same problem. Everything was unbearably slow. Tripple clicking didn’t work for selecting because SketchUp started lagging already at the second click. Opening a component took 3-4 seconds. The same with drawing a simple line. Turned out I had just forgot to close the Outliner which is a known cause for severe lag.


#65

Just installed KB4016635 but the problem persists.

KB4013429 is shown as ‘Successfully Installed’ but when I click ‘Uninstall updates’ it is not shown in that list!

I will try and remove KB4016635 as it seems to have replaced KB4013429 & report back.

Lenovo X220 with Intel HD 3000 Graphics. Windows 10. Sketchup Make 17.2.2555 64 Bit.

Edit: Well, it took 2 attempts but now KB4016635 is gone and KB4013429, although still showing in the list of successful updates, it not showing as available to uninstall either. The good news is Sketchup is back to normal. Yay! :slight_smile: However, I wonder how long before Windows tries another update and screws this up :frowning:


#66

I’m “purty” sure than Intel HD 3000 graphics are not supported for Windows 10. (Ie, you’d be forced to use a legacy Win 8/8.1 driver at best.) Also Intel has said that this generation will not get any more driver updates, so it’s days are numbered.

Intel support pages:


#67

Well, the only time I boot into Windoze is to run Sketchup. If only it ran under Linux :wink:

FWIW, this machine might be over 5 years old and is physically a bit beaten up, but it’s powered on almost constantly (99% of the time running Linux) and does everything I need. I do like Lenovo laptops :slight_smile:

But we digress… regarding the problem of buggy updates:

Almost as soon as I’d booted back into a working system Windows started downloading the same buggy update again. That is despite the fact I’ve removed it on more than one occasion. Absolutely stupid!

I tried various ways to prevent this update but found setting my WiFi as a metered connection is the only reliable way to stop it.


#68

Lack of update control is the main reason I did not upgrade (any of our machines) to Win10.


#69

That particular problem is supposed to have been addressed in the latest Creators Update - you can’t altogether STOP updates, but you can postpone installing them, and in particular, stop Windows rebooting to install an update without giving you much or any chance to stop it.

Might still not be enough to make you happy, though, and I still find Windows 7 my first choice for anything I still can’t do on a Mac. Though I have upgraded a couple of little used machines to Win10, one of which has just almost automatically updated itself to Creators Update. But I only use SU on that machine in older versions (SU 2016 and earlier) for test plugins - so not all that often now.


#70

Well this is bonkers! Ive removed/downloaded all the suggested updates for Win10 with no luck with my new PC and all these suggestions. I’m thinking about switching my new PC back to Windows 7, has anyone done that to get SU back on track? This is like working back in the dark ages of DOS.


#71

:frowning:
I can’t remove KB4015438 update. My Windows 10 is in Version 1703…
Sketchup is unusable!!!


#72

I have had a similar problem with slow Select tool every time Microsoft does a Cumulative update. I tried uninstalling and blocking, and it worked for a while, but eventually failed. While I didn’t think the graphics driver could be the problem, I finally downloaded a new driver from Intel for the HD 4000 in my Toshiba laptop. That fixed the problem, until the next Cumulative update. Again, reinstalling the same driver solved the problem. Apparently the Cumulative update is “fixing” problems that don’t exist! While I don’t like having to do the re-install of the graphics driver, it is faster and seems less painful than trying to fix the updates.


#73

Problem was solve by uninstalling a random update last week, it returned
today. This is infuriating…

Today I have re-installed the Intel HD 4000 Graphics driver… no change.
Currently downloading KB4015217, will see if that helps at all.


#74

Just download the creators update of windows and all the security updates that come after. It worked for me.


#75

I will try that tonight.


#76

I have Intel HD4000 (driver updated to latest), windows 10 updated to Creator update. Still have this problem that is annoying!


#77

On my PC, SU17, Win10 with creaters uptdate i solved the problem by changing the settings in NVIDIA 3D Settings for Sketchup to prefers grafikprozessor to NVIDIA HighPerformence Pozessor. From this time it works fine.


#78

I had the same problem with selection tool. What I did:

  • I uninstalled the latest windows updates,
  • I removed updates from Graphic Card (Intel HD 4000),
  • I reinstalled Sketchup,
    and after all above mentioned tries the problem was not solved.
    The problem was solved when I downloaded driver from official Intel web page.
    After that I reinstalled driver and after that I have reinstalled (repair) sketchup.
    Now everything is ok.

#79

This totally works for me! Thanks you. by the way, I’m running win 10, with KB4015217, dual Graphic card laptop, switched from Intel HD4000 to Nvidia 610M 2GB. And it WORKZ!!!:clap:


#80

Thanks! This worked for me too.