Selection Tool process is slow, unbearably slow

update
windows10
kb4013429
kb4013418
kb4015438

#308

To help laptops conserve battery life, by default the integrated graphics chipset is selected on laptops that also have dedicated graphics cards. Laptop users need to manually override the graphics default in the AMD or Nvidia control panels as outlined above.

In the last few months, one of the Win10 updates reset graphics preferences. One can quickly check which graphic option is being used from inside SU. Go to the Window menu > Preferences > OpenGL and click on the Details button.


#309

My selection tool has become slow again after the KB4034674 and KB4034662 updates. I’ve tried uninstalling these updates, but it doesn’t make any difference this time - it’s still slow. With HD4000 graphics there’s no hardware acceleration option in Sketchup Preferences-OpenGL as referred to by others. I have also updated to the latest graphics driver which is build 10.18.10.4653 (driver date 07/04/2017). Very frustrating that this seems to crop up quite frequently now, requiring significant time trying to find a solution. Though this time, I’m stuck.


#310

Here’s the ‘fix’ that I use. For me it lasts a few days until a Microsoft (or maybe another) driver update is done.

HD4000-gfx fix in WIndows10:

  1. download graphics driver for HD4000 (which is in my laptop) from Intel website + unzip to a folder
  2. de-install current driver for the HD4000 graphics chip (In device manager)
  3. restart windows
  4. open device-manager -> HD4000 -> update -> browse -> pick from a list -> have disk -> go to location on disc where I unzipped the driver. Choose the location of the ini-file (see step1 - in my case E:\software\drivers\hd4000_4425\Graphics).
  5. After the driver has been installed, restart windows

#311

Well, once again I am having problems with Sketchup’s selection tool. It was working August 13th, but not working today, August 14th. I can’t blame it on Windows updates, because the last one of these was August 9th. The graphics board driver has not changed either.

Currently I am running Windows 10 version 1607, OS Build 14393.1593 and Intel graphic driver version 10.18.10.4653, dated April 17, 2017
My computer has an Asus P8Z77-V LK motherboard with an Intel i5 CPU with integral Intel HD Graphics 2500
I am running Sketchup Pro 2017

Anyone find a permanent solution to the Selection tool slowing to a crawl?


#312

I hadn’t had any of the reported issues…
Then Win 10 updated itself and I got stuttering cursor, random jumping away from where I picked etc - in SketchUp, but also in web-browsers etc.
I updated my Nvidia GC drivers, things eased, BUT not completely.
I then did some digging…
I had an unused driver installed - ‘Realtek Audio’ [a legit app] - I uninstalled it, and after a restart things were fixed.
Seems that even when it’s not active it can get something called FMAPP.exe running in the background.
This captures mouse-moves and keystrokes [which sounds like a key-logger Trojan to me !], and in turn that messes with all manner of things…

Anyway so far so good, mouse back to normal…

Note:
Most of the Realtek driver subfolder’s files was emptied by the uninstall.
But then I had to delete its DriverStore subfolder, which contained two left over FMAPP.exe and dll files - after some convoluted permission/ownership tweaks - otherwise they are owned by ‘System’…


Can't find KB4013429, have extreme delays when selecting
#313

I found another solution for Intel video cards that I haven’t seen posted anywhere. Right click on the Windows desktop and look for Graphics Properties in the popup menu. Then I have a “3D” option which then has choices of “Performance”, “Balanced Mode”, “Quality” and “Custom”. Mine was on balanced and had the 5-10 second selection delay problem. Changing to performance made selections nearly instantaneous.


#314

Just reporting my issue was fixed by installing latest graphic driver.

Full: Windows 10 64bits / Intel HD4000. Using Sketchup 2016, had the freeze problem after every select/unselect, installed Sketchup make 2017 to check if that helped but the issue was also seen here. Couldn’t find the update indicated by some in order to uninstall it so went ahead and downloaded the latest graphic driver (for Intel HD 4000) which after the restart seemed to have fixed the issue.


#315

I found the final solution, all you need is to run the program in windows 7 compability mode.


#316

Sorry, putting Sketchup 2017 in Windows 7 compatibility more did not work for me.


#317

Does anyone has a reliable solution for this problem? I’ve tried every possible fix that was suggested and yet it just work sometime then the problem resurface the next reboot. This is unbearable! Trimble?


#318

It is indeed annoying for those who are affected. Unfortunately the solution doesn’t appear to be within Trimble’s control. As you can see by reading through this thread, the problem stems primarily from bad Windows update files although a few users have found some relief with graphics driver updates. Apparently the problem is more widespread than just SketchUp, too.


#319

Not under Trimble’s control? That’s why the problem hasn’t been fixed for so long. For my years of fixing software problems, the very first step to fixing any problem is for the team to agree that “we have a problem” then next step is to describe the problem, follow with duplicating the problem. Once that’s done, any problem can be easily fixed!


#320

So what you’re saying is Microsoft should identify the problem and fix it. I agree wholeheartedly.


#321

The same Windows updates have caused the same kind of problems for several different 3D applications, of which SketchUp is only one. Many 3D application vendors recommend that their users do not install the Windows 10 Creators update.


#322

Don’t get me wrong. I am the biggest fan of Sketchup and I also believe that the problem is caused by Windows which I am not a fan of. However, besides Sketchup, I also use other CADs which rely heavily on OpenGL but do not have the same problem. So here’s the thing. If other CADs can sidestep this elusive Windows deficiency, why can’t Trimble? Look at the statistic of this thread. The first post is more than a year ago. Both version 2016 and the latest 2017 have the same issue. Take a look of the number of users looking at this thread for solution. There could be thousands of users suffering this problem right now. Trimble could do us a huge favor by finding out what it is that cause Sketchup to run into this Windows deficiency and provide relief to these poor souls, myself included. So, Trimble, how about stepping up to the plate to go battle for your user base? Or, continue to wait for Microsoft to fix the problem.


#323

Totally agree!..Trimble need to get hold of this right away…currently cannot work on a time pressured large design for a new sports building…and have spent last 3 hours trying various uninstall…which did work but now doesn’t and takes hours out my week…where are you Trimble???, I’ve paid for this which is gauling

‘is there anybody out there?’ Pink Floyd

‘Baby come back’ - Player

‘Sorry seems to be the hardest word’ - Elton John


#324

If you have immediate needs, contact support. If you want us to stop Microsoft from doing updates, don’t hold your breath.


#325

This worked for me and took 2 seconds!!! THANK YOU!!!


#326

Barry,

I am heart broken from such a response from a Sketchup team member. As a casual user since Version 8. I’ve been the most ardent advocate of Sketchup. Because of Sketchup’s innovative interface which allows for the shortest learning curve in any 3-D CAD modelling software, Sketchup has single handedly created the most creative 3-D modeling outlet for both casual users and professionals alike. I do wish for the best successes with Sketchup in the future. So whenever Trimble has decided to tackle this little problem, here are a few things I’ve noticed:

  1. The problem seems to associated with OpenGL. Curiously, boot up sequence sometimes make the problem goes away.
  2. The earliest manifestation of this problem occurs starting with Sketchup 2015. I ran both Sketchup 2014 and 2015 side-by-side loading the same copy of a drawing (renamed differently off course) and 2015 Sketchup would show the issue. Hope it will help to narrow the scope down.

I hope Trimble will consider spending the resources to fix this issue. I just don’t think Microsoft cares if Sketchup working with Windows or not.


#327

This thread has nothing to do with 2015. To the majority of people, this is discussing specific Win 10 updates that mucked up things.

If you have a specific issue that is different from this topic that is not affected by the key words “update windows10 kb4013429 kb4013418 kb4015438”, please start a new thread, so we can track what your real problem is, and be specific with graphic card and OS version. Win 10 came out in July 2015, and SketchUp 2015 was released before that (meaning that neither 2014 nor 2015 are supported on Win 10 and this topic).