Selection Tool process is slow, unbearably slow

update
windows10
kb4013429
kb4013418
kb4015438

#288

I found in the past that just cold booting the computer would cause the slow selection tool problem and, if I clicked on start and selected power, then Restart, it would work fine. I repeated this a number of times and each time I did a cold boot, by shutting down the computer instead of restarting, waiting a minute then pressing start, the problem came back. Then I noticed upon startup that there was a problem with the Intel Technology Access program and it displayed a window asking me if I want to repair or remove the program. After investigating the Intel Technology Access program I saw it was only used for tablets with touch screens so I removed it and the problem seems to be gone.


#289

Folks, After having this issue on and off for a few weeks, I’ve found a solution for me (with a dedicated graphics card)

I believe a windows update set my sketchup default graphic driver to the Intel integrated HD which caused all sorts of slowness issues, not just selection tool. I loaded my graphics utility (Nvidia control panel in my case) and forced sketchup to use the Nvidia card. This has worked well and solved all issues I had. Try it and report back on here if it works for you.

You can also find out which card sketchup is using in the window>preferences>openGL settings.


#290

Yeah @AndrewT, I believe a Windows update resetting graphics preferences was mentioned in this forum, but it’s well worth mentioning this again.

There’s no one-size-fits-all solution for Intel drivers. A lot depends on what the computer manufacturer will allow as the Intel graphics chipset is built into either the MB or CPU and individual manufacturers have the option to tweak drivers to best work on their product. @arq.lisbethv3, check with your computer manufacturer for latest driver, but you may be able to go directly to the Intel website for the latest driver - it depends…


#291

3 Days now since I removed the Intel Technology Access program and the slow selection tool problem is gone. Been cold booting and restarting repeatedly and cannot cause the issue to rear its ugly head any longer. Hope this helps someone else out there…


#292

Just following my last post where I did a clean re-install of Sketchup and that fixed it, the bug is back now about 3 weeks later - presumably triggered by another Win 10 update (that’s all I can think of as nothing else has changed). Unfortunately a clean re-install of Sketchup ISN’T fixing the problem now. I’m getting a 4 second day when double / tripple clicking on objects and sometimes a 10+ second delay when changing to other tools. I’ll try some of the other suggestions on here (which I tried before but they didn’t work). Unfortunately as it stands this is completely unusable. :frowning:


#293

Thanks Kinonato! That did it for me, also. It seems that the creators update resets EVERYTHING to some default.
The select tool was painfully slow as was the zoom window. Sketchup now works as great as it always did.

Many thanks and best regards,
Laprivan


#294

Sketchup used to run OK on my laptop and then suddenly started the 30 second selection delay problem sometime. I finally came across this in a different forum and it fixed my version in Windows 10.

Right Click Sketchup Icon on desktop
Click Properties
Click Compatibility
"Check" "Disable display scaling on high DPI settings.

Selection tool is once again instantaneous for all practical purposes.


#295

Same issue. Sometimes resolved by installing graphics card driver update or restoring system back to earlier time. Just got tired of dealing with this and installed new AMD graphics card to replace motherboard Intel graphics. So it cost $50 to keep using Sketchup Make…well worth it! Seems to have completely solved the problem. Now wait for next Windows update to confirm. Hopeful/


#296

Over 2 weeks now since I removed the Intel Technology Access program and the slow selection tool problem is gone for good. Been cold booting and restarting repeatedly and cannot cause the issue any longer. No reinstall of Sketchup, no updating of graphics card or drivers, no worrying about Windows updates. Problem solved as far as I’m concerned.


#297

Sadly I seem not to have the Intel TAD install, but still recieved the issue with the update to Windows Creator (kind of ironic as I am not able to create anything now).

But mine was solved by fetching Intels driver update ultility and then let it do what it wanted. It turns out that Windows Creator doesn’t come with the latest Intel drivers (in my case Creator just came yesterday and Intel’s are from May.


#298

Managed to solve the slow response problem, scan PC with Intel Driver Update Utility Installer.exe and installed win64_153345.4653.exe


New laptop: Windows 10: compatibility issues?
#299

Hi Dan, I am having the same trouble with my Sketchup Make, I use Windows 10, 64 bit version. Selection tool takes a long time to respond. I have followed the conversation thread and seems that this comment you have made was conclusive and sorted out the problem back in March. My challenge is that this has just started happening to me now. I changed my operating system to Windows 10 back in June, after this conversation thread happened, and the stalling has only just recently started happening. I have updated my Intel HD 4000 driver and Windows 10 and still the same problem. Do you have any recommendations? Thanks for your help, Jarrad


#300

I have had problems with the slow selection tool, too, off and on for many months. I thought I had found a predictable solution by installing an old graphics driver and letting Windows update the driver. It worked a few times, but the last time it failed. Miraculously, I updated Windows with the latest update: 2017-07 Cumulative Update for Windows 10 Version 1703 for x64-based Systems (KB4032188) and the selection tool started working properly again. I’m using the HD 4000 on a Toshiba Satellite P875 with Windows 10 - 64 bit. Maybe Microsoft or Intel got around to fixing their driver. I hope!


#301

That worked! Although I updated my system yesterday I had a look in the history and noticed that the update you mentioned failed to update, I did it again and everything is working as it should. Thanks for the advice.


#302

Once again having problems with the Selection tool slowing after Windows 10 Updates. I contacted MIcrosoft, but they basically said it is a Sketchup problem. I hope it gets fixed soon, or I will have to abandon Sketchup (or Windows or both). Following is a short history of my temporary solutions to the problem on my machine:
Revert from build 1703 to 1607 helped for a few months
Uninstalled Microsoft Windows Security Update KB4025339 helped until that update was reinstalled by Microsoft
Uninstalled Cumulative update KB4025339 (Windows keeps re-installing it)
Went from version 14393 to 15063 - seemed to work, but the next day not working again.
I updated my Intel graphics drivers, but that had no effect. I have also tried a number of things suggested in this
forum, but the only thing that seems to work (at least in the short term) is uninstalling Windows updates.


#303

I received the same update and again I had to fix a sloooow selection process. win10X64, hd4000.


#304

I want my money back.


#305

RESOLVED RESOLVED RESOLVED RESOLVED

SketchUp 2017 Slow - RESOLVED - Slow Selection Tool - select tool

I made a video explaining step by step takes less than 3 minutes

I hope I have helped.


#306

It may be worthwhile to go to the Windows Update site to check if there are any relevant updates that have not been added to the automatic update cue. For example, recently there were some updates to .NET Framework that adversely affected some Win 7 and 8 setups. Patches to fix that NET problem were not subsequently added as an automatic update.


#307

I also have been having this problem off and on for a frustratingly long time. I just used part of Godero’s video and it seemed to solve the issue. The only steps I needed to take were:

  1. Open the NVIDIA Control Panel (usually accessible from the hidden icons tray)
  2. Select the “program settings” tab
  3. Choose Sketchup as the program to customize
  4. Select my high performace graphics processor (formerly set to the integrated graphics by default)
  5. Hit Apply

That took care of it. Hopefully it won’t come back!