Selection Tool process is slow, unbearably slow



An update took place outside of active hours that fixed my problem again.


Well, I have Intel HD 4000 and opengl 4.0 installed. I have the slow select issue!


A 100% OpenGL 3.0 compliant driver is only is just one part for happy sketching in SU17. There are ~300 functions calls in the OpenGL library. Sometimes driver developers leave out some obscure functions to the detriment of SU. Also, in the case of integrated Intel graphics chipsets, computer manufactures often tweak the drivers to fine tune the drivers to best match the hardware - which may or may not include all required OpenGL functionality. Check with your computer manufacture for latest graphics driver. Don’t depend on Windows Update for the best/latest driver. Although some computers with integrated Intel chipset will allow driver downloads from the Intel website.

Search this forum for “Intel 4000” for more ‘fun’ facts/issues to your graphics chipset. Intel has done a good job incorporating OpenGL into its drivers lately. But you may need to jump through some hoops to get the right driver - and sometimes the latest driver may not be the best. But usually the latest driver is the best.

Some Windows 10 automatic updates have had some unwanted SU performance consequences. This thread and other go through this seemingly never-ending issue. grrrr…


I have installed (re-installed many times) Intel orginal driver, trying every tweaks I saw on this thread.
I have tried 2015, 2016 and 2017 release. The issue is still there.

I can’t beleive trimble can’t find a patch to this problem.


Has anyone seen a correlation between this problem and issues with the Intel Technology Access Driver? I turned on my laptop yesterday and a message appeared asking if I wanted to remove or repair Intel Technology Access. Apparently there was some kind of error during a cold boot. After some research I find that this driver works mostly for Tablets. The Intel® Technology Access uses the 2-in-1 sensor and display setting detection to the browser applications using web services. The 2-in-1 sensor determines the mode of a device (for example: tablet mode or clamshell mode). The Display settings detect and get the screen resolution and orientation values. It also uses the Microsoft Windows COM sensors for accelerometer, ambient light, compass, inclinometer & orientation. Since my laptop doesn’t have a touchscreen and is never used as a tablet I removed it from my system and so far everything is working well with SU17.


I think the same, and it is incredible that we are many people who have the same problem and without solving it.


Yeah. You’d think Microsoft would be more responsive to its users.


Folks after reading all of these posts and trying a few things myself including changing the HD graphics settings to Performance instead of balanced, rolling back yet again to a previous version of the HD 4000 device driver ( that worked once) but now even that has broken all three versions of SU - 2015, 2016, and 2017. And I saw another post where the fellow is using the exact same version of the Intel HD driver as me - his is reportedly working and mine is not !!!

the only thing that has been successful with SU 2016 is changing the preferences for OpenGL to turn off hardware acceleration. Selection tool works as it is supposed to now…

Hope this helps …


…Update: Been restarting the computer all afternoon now. Trying cold boots and quick restarts so far the problem is gone. Can’t seem to make make SU17 repeat the slow selection tool problem at all now. Seems that removing Intel Technology Access solves this problem for me anyway.


Mmm no, they are the same or worse.
But I think I found something. I had sketchup17 installed again to test the selection tool and the same takes time to respond then uninstall the program enter the registry “REGEDIT” I searched all the records of “sketchup 2017” Logs and delete them all, reboot, reinstalled, opened and worked With normality until I started to install several plugins and again failed again :tired_face: :angry::rage::triumph::sob: (this was last night)…
And today I repeated the process but without installing the plugins so I’ll test how it goes without them ?.
(Sorry if I wrote something wrong, my language is not English).

I have an Intel HD 4000 card & Windows 10, version 1703 . SO 15063.

I hope this information can be read by SKETCHUP OR TRIMBLE WORKERS. I think it’s a system registry problem maybe with windows 10 or I dont know?. My ability comes here :neutral_face: . It is tedious to be manually cleaning the Registers and installing it several times.


Reinstall: Are you using Run as administrator or just double clicking on the installer file?

“install several plugins”? Which ones?


The process I performed was:

  1. Delete Sketchup17
  2. Open, run and then “Regedit”, search for “sketchup 2017” and Delete each registry entry.
  3. Restart your pc’s laptop.
  4. Install as “Administrator”.
  5. Use with normality.
    But it is not the final solution.


Does this mean you right clicked on the installer file and chose Run as administrator from the Context menu? Or did you do something else to install SketchUp?


Exactly what?

Why is it so hard to get you to provide clear answers to questions? We’re trying to help you. Make it possible for us to do so.


Sorry but I thought you were a user so my way of responding or writing is like that, besides English is not my native language.
Are you asking me if I use the context menu to select “Run as Administrator”? And I answered “exactly” because I am reaffirming that yes (sorry!).
I did that: I opened the context menu look for the option to “run as administrator” and I clicked.


There were two questions in my post.

OK. This is the first time you explicitly wrote that. It’s an important detail so it’s important that you include that in the steps you went through.

You also wrote that the problem started after you installed several plugins. I asked which plugins but you haven’t answered that yet. If the problem didn’t start again until you installed some plugin, perhaps it is that plugin that is the problem.


Yes, I previously did:

  1. I installed the “SketchUcation” plugin, with more plugins than Ucation offers.
  2. The “selection tool” began to fail.
  3. Here was when I decided to go back to do the installation that explains.

Maybe that’s those plugins.
But I have my doubts, because this same step with sketchup 2016 I used it without the plugins and it did not work. Then I read a user who installed “sketchup 2016 x32” on an “x64” machine and it worked !, and I also work with some bugs but it works better than sketchup2017.

I don’t want to give up because I have and I need to use the new Vray 3.4.


Hi, can you explain, how did you do that restart? or Is it simply restarting the computer?..
And how many times should you do?.


I had to install SU2016 x32 on my x64 computer with windows10 and change Open GL turn off hardware acceleration.


@arq.lisbethv3, disabling hardware acceleration in SU16 means SU is bypassing the Intel graphics driver and your computer is using the CPU for everything.

SU16 is not happy with your Intel HD 4000 driver in your machine. SU17 introduced new, required hardware and software requirements. From this point forward, SU requires a computer that can use hardware acceleration - meaning computers need graphics hardware (graphics card or integrated chipset) and its associated, OpenGL 3.0 supporting graphics driver.