Selection tool does not work for a face

sketchup
advice

#1

I have just started up with SketchUp. My Version is Pro 2017. Building a new model the selct tool works for faces in the beginning, but at one stage it stops working and I am not able to activate any face, either by single, double or triple clicking. The screen background is all grey. However, the select tool still works for lines (they turn blue and may be modified/deleted). Can anybody help me with this?


#2

Can you share the SKP file you’re working on? Let us see if it is something related to the model.


#3

Is your Graphics Card driver up to date ?
When you installed SketchUp did you select the installer exe file’s icon [probably in your Downloads folder?] and use the context-menu option “Run as administrator” ?
If not, do it now, choose ‘Repair’ …


#4

have you switched to ‘Wireframe’ accidentally?

john


#5

Thank you for your answer!
I have attached the file to this reply.
However, I have tried in other new files and find the problem to be the same in any file.
In my computer I cannot make face active (turn to dotted surface), e.g. to use Push/Pull command.
Only edges will turn blue with Select tool.
Hope you can help me:

Best regards
Bjahus

Modell 42-1.skp (168 KB)


#6

You have selected wireframe mode for viewing the model. In wireframe mode there are no faces to select! Try choosing one of the other modes such as hidden line or shaded and faces will appear (where they exist).


#7

That was my suspicion. Thanks for confirming.


#8

Thanks a lot!
(I have just started with this program. This is probably typical beginners’ problem.)

Best regards
Bjarte


#9

It’s all in the details.


#10

Hello and really sorry for my bad english.

I have a similar problem with SketchUp 2017 Pro.
I don’t see what face is selected. (On SketchUp 2016 it’s working)
Both SU’s running on the same virtual machine.


#11

I assume this means you are running it on Linux.
SU2017 needs better graphic drivers than linux can deliver in a virtual environment.


#12

Virtual machine work with Windows 7 64bits.


#13

Does the VM include a graphics driver that you can try to update? If SU 2017 works at all, this might be the case.


#14

The critical difference between SU 2016 and 2017 is that 2017 REQUIRES a graphics card and driver with full support for OpenGL 3.0 or higher.

Your virtual machine may not support that, even if your real graphics card does. For example, Parallels VMs on Mac only supports OpenGL 2.0, so wont run SU 2017 at all in a VM, though 2017 runs natively very well.


#15

Thanks for answer.

I use VMware for Virtual machine.

This is OpenGL check:


#16


#17

Sorry, on my phone - image is too small to read, and won’t enlarge.

Now looking on my computer. It seems to say OpenGL 3.0, but perhaps not fully implemented?

The symptoms look graphics card/driver related. Sorry, but I don’t think I can help further.


#18

I would check if there is an update for the Gallium driver.

Although unsupported, using a VM may work if the graphics system, as said here, supports OpenGL 3.0. I have tried successfully in a Citrix environment with a Nvidia Grid graphics system.


#19

@Anssi driver is up to date…


#20

This topic was automatically closed after 91 days. New replies are no longer allowed.