Can't Select Faces (most of the time)

Hi Folks,

Just upgraded to SketchUp Pro and am tearing my hair out trying to figure out why I can’t reliably select faces in a model. The model itself is fairly complex, but I hid a bunch of stuff and tested on a new face I extruded and still no luck. In this case I can select the top face, any edge, but the side faces can only be selected if I do a box selection.

Curiously, if I do the same in a new file, I can select things fine. Also, if I save a component as a model I can also select things fine there as well.

I can’t for the life of me figure out if I’ve changed some setting somewhere or if this is an (infuriating) bug. Things I’ve checked:

  • Rebooted, restarted, ran as Admin, etc.
  • Toggled the “Use fast feedback” setting.
  • Verified I’m not in wireframe mode (as evidenced here that faces are selectable, just not with a single/double click)

I’m relatively new to SketchUp, but have been 3D modelling for 20+ years so am completely stumped. What am I missing?

Upload the .skp file so we can see what you’ve got.

Are you in Xray mode? You will be able to see the back faces but not select them without getting the face in front of it you are trying to select through. You can select back faces with a selection box.

check View>face style>X-ray, is it checked?

If you orbit the model can you select other faces?

Switch to ‘Perspective’ mode and see if that block is viewed from beneath.
It’s all weird though but pespective at least makes things less tricky.

This did it! I was in parallel point perspective (likely from a lot of top down work mapping against a blueprint). When I switched to perspective, everything disappeared. Once I got back to the model (by zoom selecting on an object), I could select everything again.

So it seems like I was most likely viewing the model from extremely far away and not noticing because perspective was turned off. This explains a lot of weird graphical glitchiness I was seeing as well (i.e. with z-ordering flickering).

Thanks everyone for your help!

Strange camera distance is one of the problems with drawing in parallel projection. Zoom on the parallel projection screen is done by scaling the viewport, not by moving the camera. So it is possible to get the camera very far away from the model with no visual clue. But, as you noted, strange things start to happen because SketchUp is constantly struggling to deal with model effects that are tiny compared to the camera distance yet “blown up” so that they look normal.