Scenes disappear in parallel view

I have a strange bug.
I have multiple scenes in parallel mode, elevations and Plan views that disappear. I can see the image during the changing scene animation but as soon as it set, it disappear. Zoom, changing view mode, switch tag, purge, fix problem, open GL setting, fog on/off… nothing works, but as soon as I orbit, the image is back… but I lost my cam position, and therefore my layout viewports are a mess!

Because those scenes are linked to layout viewports, I cannot just re-do them. I need the have the camera exactly at the same spot. (huge classic lack with layout tmho!)

I cannot share the file. I tried to create other geometry and clear mine so I could share the model with you but the problem got solved when I delete my model so it’s probably something in my model to create the bug.

Thankfully I found a fix for my meeting presentation with the client tomorrow morning. I used Eneroth Camera Memory (Once again, she saved my life.) I go on the scene where the image disappear, I “Put To Memory” the cam. Orbit slightly (image is back), Retrieve From Memory (image still there) and update the scene. Thanks god it works and I could update my layout presentation.

I also have another weird bug with a scene disappearing but this is cause by the fog setting moving by theirself. I already mentioned the problem to SketchUp team. It’s annoying but easily fixable. My actual problem is not cause by fog as the fog feature is off.

Anyone have witness this problem before?

You should read my post here:

Part of it gives instructions on a Ruby script you can run to fix all of the scenes. Once they are fixed you should save the model as a copy, then try linking in the copy to your LayOut document. Might as well make it be a copy of the LayOut document, so you can go back to where you were if things don’t work out.


For me, switching to Perspective and back to Parallel and saving the scene worked. The SketchUp view extents changed, but the crop in LayOut was preserved,

1 Like

I tried that but it didn’t work: When I switch back to parallel, the image was showing but the camera was now thousand of feet way back. The model looks very small, so it lost the cam position.

Looking at Colin’s reply, this probably means the bug is under investigation. I’m confident it will be fixed in the future. Thanks for your reply and support to both of you.

1 Like

This happened to me too, but as I said, for me, it didn’t affect the crop and scale of the viewport in LayOut. The camera gets moved outside the project.


Rolling back to sketchup model v2021 and layout v2021 fixed this for me, scenes all became visible again.


before going to parallel view select one group or component that is in the view… select scene > press enter … You will go inside of the group and view will readjust automatically. > update scene.
seems to be working temporarily… after I edit something and then go again to that view it is again gone…