Rendering Issue in SketchUp 2023

I thought I was going crazy :scream:

I thought maybe my graphics card was dying :sob:

But why would SketchUp render my “modelling” scene perfectly but my other elevation and plans scenes disastrously :thinking:

I did a repair as administrator but the problem was still there.

I checked with 2022 and it was not a problem.

Then I found that my modelling scene where there was no problem was perspective and the other scenes were parallel.

In this gif I start off as perspective and then change it to parallel:


As perspective I can zoom and orbit to my hearts content and there is no issue, but when I change to parallel the rendering goes crazy and the model “disappears”.

1 Like

I’ve been noticing this with my Space Mouse. I have one of the keys set to toggle Parallel Projection. It seems like every 5th or 6th time I toggle, or depending on where my cursor is, the camera goes bananas and I have to use Zoom Extents to get the view of the model back in the proper place. It doesn’t seem to happen if I use the pull-down menu to change perspective, so maybe it’s the rapid change that’s causing some kind of conflict.

1 Like

When you are in parallel projection, some of the faces disappear, then the model drifts off screen. Are you seeing that as two problems? Could it be that when the faces disappear you are now orbiting on empty space, which would make the whole scene move, instead of orbiting around the model?

I haven’t seen faces disappear like that. Does it happen with all models?

Here I go more slowly – I start out in parallel:


It’s happening on all models that I tested so far.

I don’t believe that this is two problems - maybe this gif shows it more clearly…?

It’s happening on models that I created as far back as August 2021.

I opened a file from June 2020 and it does not happen.

This is in SketchUp 2023 – in SketchUp 2022 this does not happen.

What extensions are installed?

This sort of looks like what we’ve seen on occasion when users have their camera placed at a huge distance from the model. What happens if you go to Perspective? Can you show a video capture of doing that?

I’ve been having strange behaviours with photomatch too, in 2023
When setting up new axes first (which I always do), and using photomatch, it randomly messes up everything by repositioning the axes on its own
(I’m aware it’s not the exact same issue, but it looks like it)

Extensions – the usual – nothing weird or out of date.

This gif starts in perspective then changes to parallel.

When the cube disappears I change back to perspective and the cube re-appears.


( The cube is a 5.0m³ )

Are the model axes in their default location? Is there anything besides the cube in the model? If you select it and then choose Edit>Invert Selection does Entity Info show anything selected?

Strange. I just recreated this 5m3 cube in SketchUp Pro on a Windows machine (GeForce GTX 1660) and when I put it in parallel, I can’t get the faces to disappear like that. The model disappears when I toggle off parallel after moving around for a bit (again, have to use Zoom Extents to get it back into view), but I can’t seem to replicate your error.

Just the cube Dave – no lurking components in the model.

Axes are default.

It’s a default template I have.

I do most of my modelling in perspective so not such a big deal, but occasionally, e.g. when I’m using Curic Stretch, I need to go into parallel to make sure I’m grabbing the correct vertices.

maybe it’s a Windows thing :wink:

Weird. I can’t duplicate it here.

My thought is to put your cube in a different template and try it. If the behavior still occurs disable the extensions and try again.

I didn’t want to hear what Adam said above, but, yes Dave it seems that it is an extension :frowning_face:

Renamed the 2023 folder in Roaming because for some reason some extensions weren’t disabling.

And the problem went away?

Assuming yes, you should have a new Plugins folder in addition to your renamed one. Copy half of the extensions from your renamed folder into the new Plugins folder. Restart SketchUp and see if you have the same issue. If you don’t quit SketchUp, copy half of the remaining extensions over and try again. When you finally get the problem again you should be able to narrow it down to the specific extension.

Yes Dave – problem went away.

I think it could be Curic Scale++.

I deleted the newly formed 2023 folder and renamed back my original.

Problem was back.

Thinking about it, I didn’t have this problem last week as I used Curic Stretch in perspective mode a number of times – the only thing that has changed from last week is that I installed Scale++.

I removed Scale++ and the problem is not occurring – reinstall Scale++ and the problem comes back.

It occurred to me that this could be related to the new Overlays feature but Solid Inspector is not causing this problem in Overlay mode.



Well, at least you and we know what the offending extension is and that’s good. Hopefully he can fix this.

I don’t think that just because one extension taking advantage of the new overlay works fine means that the problem doesn’t lie there.
Overlay is not a feature really, just some kind of freedom for plugins to keep running while cohabiting with native tools which basically could lead to many problems