Save As component and then edit yields strange camera behavior

components

#1

I am working on a complex model and I am saving components from the master project to more manageable files that I can import into other projects.

I build a component in the master project, create the component and then select Save As…

This creates a new file with only the component. When I go to edit this file, the camera view behaves strangely-- as if the axes are in the wrong place or orientation. When I hit F12 to view from above I get a side view. Moving the axes doesn’t seem to affect how the camera view works in this new file. The behavior is similar to when you incorrectly place the axes upside down, but the axes appear correct.

When I view the component back in the original master project, the component’s camera views and axes appear to be in the correct location.

Is there something that I am missing or doing wrong? I wound appreciate any help I can get!


#2

can you share the component file?


#3

Ceiling Trap.skp (30.4 KB)

Thanks for the speedy reply!

I am very curious to hear what the file orients to on your machine!


#4

This is the way it opens for me. The view is from the top.

The face orientation of the frame on the right is incorrect. You should correct them.

Are you just making a bunch of components in a common file for later use?


#5

When you try to pan and orbit does the model behave strangely?

I am trying to separate different components mostly for my own workflow and because I often need to re-use the components later in other projects. I am trying to stop re-creating the wheel.

I will save another version of the component to give the correct starting orientation.

Please standby


#6

No. It behaves as I would expect. It looks like a tall box with dimensions and the frame. I’ve corrected the face orientation.


#7

Ceiling Trap Unedited.skp (10.8 KB)

When I save the component from the master model, it orients this way. When you hit either F12 or F11 the orientation changes from this layout. To what I would consider the “side” view.

This is the “correct” orientation that I am expecting. A long flat box laying on its back, in you will.


#8

Do you know that the Blue axis points up? When you create the component the component’s axes will be aligned with the model axes. Are you sure that your model axes haven’t been moved?

When I opened the last one the view was looking up at the bottom of the box. With a proper view looking at the sides of the box, it looks like this.

According to the axes, your view shows the camera looking up from below the box. The box is standing on its small face on the ground plane.

I expect what you really want looks more like this. I’ve rotated the box so it’s laying “on its back.” Noticed the axis orientation.


#9

Wow, this is really confusing. I am reasonably sure that I have somehow confused the axes in the original master project. Let me do this:

I will screenshot the original project and leave the component selected.

Now I press F12 to look at it from above:

When I save the component it gets confused. I am noticing that the axis in the original document is incorrect looking but it behaves the way I expect with the F12, F11 views. What I mean is that the Blue axis is pointing sideways instead of up, but the views from Top and Iso act correctly.


#10

there is something with the first attachement, when you zoom out (a long way) you would need to use zoom extends a few times (sometimes 4) That is unusual. deleting the guides did not make a difference. What is/was on the ‘Ceiling Acoustic’ Layer?

FWIW. I wouldn’t ‘group’ the dimensions in a component, this will ‘untie’ them from the geometry.
You can assign the ‘Dimension’ Layer directly.

edit:


#11

How about uploading the entire model file so we can see how you have the axes set?


#12

The “Ceiling Acoustic” layer is from the master project to allow me to turn off the ceiling components so I can see the other parts of the model more easily.

I need to sanitize client information from Master file before I post it. Please standby.


#13

Thanks for your patience. The file appears to be too big to upload.

Even after I purged a some of the components…

Grrr. standby please.


#14

The grouping of the dimensions causes the strange zoom behavior.

Exploding resolved the zoom extends


#15

control-room-section-DESIGNS1-ForForumHelp.skp (383.4 KB)

It was materials from the 3D warehouse items. Gi-Normous!

In your screenshot video, the orientation is actually not supposed to be vertical like that. Please check out the other file “CeilingTrap Unedited”


#16

image.png

https://extensions.sketchup.com/en/content/material-resizer


#17

You’ve got the model axes screwed up with Green pointing upward. Fixing the axes ought to fix the issue with your expectations.

Right click on the axes and choose Reset.

Then you’ll need to change the axces on the components and set them correctly to align with the corrected model axes.


#18

That looks useful!


#19

I tried to mention that the axes colors are oriented wrong, but the model behaves correctly when I change views. Is it possible that I have additional axes in other components that are competing, for lack of a better term.


#20

I think that the reset axes was the thing that I should have done all along. I don’t think I knew about that…

The confusion was how the axes can have green for up/down but still act as if blue is Up/Down

Thanks for all your help, fellow travelers!