Component won't stay put, seems to be connected to the camera

I downloaded a component from the 3D warehouse, this one:


This is a model of some 3D folding chairs with 2D women sitting in them. When I import it into my model and place it, it doesn’t stay where I put it. It moves around when I move the camera. It’s very strange, like it’s parented to the camera in some odd way. I suspected “Always Face Camera” was turned on in the component, but I unchecked that box, and it had no effect. I tried exploding and re-creating the components, but no joy.

Any idea how to fix this? I could find no help topic that covers this.
Thanks!

the problem with the model is the axis is away. Just enter the model copy or cut the entire model come out of the model and paste outside the component and group it and then c it will work

If you want it to remain a face camera component, just right click on the component and choose Change Axes. Move the component’s axes to the center, perhaps. Or wherever it makes sense to you to have the pivot point. You should be able to turn off the Face Camera behavior by unticking the box in the Edit tab of the Components window but those ladies are much to look at from the front so you might not want to do that.

Why does the axis being off create the problem I’m seeing? Why is it parented to the camera?
I would like the the 2D women to always face camera, but not the chairs.

I am confused about how to change the axis. It’s not as simple as it sounds. I tried that and ended up with a very messed up axis. I would like this group to always sit flat on the ground. Why is that so difficult?

I will try the cut and paste method.

Thanks!

The component’s origin forms the pivot point of the component. There has to be a pivot somewhere and the origin is it. If you want the women to pivot on the chairs, you’ll have to set their origins appropriately. Just make sure the chairs are not set to face the camera. Instead of cut and paste, just explode the big component. Then edit each of the women to center their origins and give them the face camera attribute.

I see now. The whole group of women was set to face camera. I couldn’t turn it off, but when I cut the groups and pasted them into a new document, that fixed it. Why? I don’t know. The women do not face camera, but I’ve decided that’s not important. And you’re right they aren’t much to look at. I tried to edit them so that their legs wouldn’t penetrate the floor, but I finally gave up. They are a mess. Not worth the time to fix.

Thanks!