Component "Always face camera" Forces Component into Wrong Angle

Hello community,
I am importing a size reference .png drawing of a pilot I created in Photoshop. It makes no difference whether I import as image or as texture. When I choose “Always face camera”, the component is forced into an arbitrary angle right before the ‘always face’ effect is applied. So the component ends up always facing the camera, sure, but at a weird angle. I have tried exploding first, not exploding, triple-clicking first, double-clicking, applying drawing to a rectangle then grouping and making component…no luck. I tested with a simple black dot png drawing and same thing happens. What am I doing wrong?

Attaching .skp so you can see…

SpacePilotCompomnent.skp (2.6 MB)

Not a necessary step but anyway… purge your model so you only have one placed instance in modeling space. Be sure you do have that one placed or all will be gone from the ‘In Model’ component library

  • In your component library change that component to not face the camera
  • In modeling space change the component’s axes so red is along the base and green is running perpendicular from the back of the texture. Blue will be pointing up.
    (now you have its axes incorrectly)
  • turm to ‘Parallel’ projection and Front view
  • now in your ‘In Model’ component library change the component’s property back to ‘Always Face Camera’
1 Like

You’re awesome! That worked. So now I see it was an axes issue.
I had to do a little playing with your instructions a bit because I was trying to make a component without having to explode it (since exploding the image would create an unwanted rectangular border), but it wouldn’t let me have both things. However, I noticed you can make the individual frames of the rectangle invisible by selecting each segment of the box and hitting the eye icon for each segment in the entity box, so all good. Thanks again!

It feels like you are working too hard for this. Just open the component, select the contents and rotate it into place. Then use shift with the eraser tool to hide the edges.
No need to explode anything or even change axes.

1 Like

Thank you for your reply, but I think you missed where the problem is. Sketch up does not import a Photoshop .png as an automatic component. You have to import the .png as a .png (image or texture), ‘then’ convert it into a component. Right-clicking the freshly imported .png does not give me the option of “Make component” regardless of how I import it. I am forced to explode it first. It is the action of THEN turning it into a component that is including an inexplicable, automated, arbitrary rotation out of the blue on my SketchUp. Apparently, my SketchUp is importing the 2D image with axes skewed.

Actually, the image you were working with was an already pre-rotated image. ALL my imported 2D images are imported either flat on the ground (requiring me to stand them up) or in the opposite side of the green axis. Also, it is not allowing me to erase the borders like your video and 99% of Google searches show. On my laptop, erasing any line inside the object as you did erases the entire pilot. It’s kind of like a thousand 30-second Google instructional videos for one armed people titled, “Look how easy it is to tie your shoes with two hands” heheh.
It might be caused by my Mac OS/SketchUp combination (shrug). I am temporarily forced to continue avoiding upgrading away from High Sierra due to myriad issues I won’t get into here.

Can you attach one of your images.

Here is clip of my import (as image or as texture makes no difference)

And the current WIP. My intent is to use this artist’s concept for a highly-edited wireframe pilot to place next to up and coming ship designs.

Orbit the camera so the import isn’t being forced to the ground plane.

Can you attach the .png you are using.

Here I have made a quick png from your jpg without bothering with the detail.
I import it with the camera at an appropriate angle, front on.
Then ignore the option I have to Make Component and explode the png which gives the hard edges.
I then use SHIFT with the eraser tool, note how the icon changes, to hide those hard edges. You could also do this by double click, shift single click to deselect the face, then hide the edges.
Then make it a face me component.

1 Like

Sigh…On this video, ‘your’ SketchUp is giving you the Make Component option the moment you import. Mine does not. This is what I think you did not see in my video. See 0:20 in my video. It’s okay really, Wo3Dan was able to resolve it. Thank you though for your effort.

I made the point of ignoring that option and showed you how to deal with it without using that ‘unavailable’ option.

By the way, the make component function is a recent addition, not available in your version.

Yes, Make Component ‘is’ available in my version. The platform/OS/suite combination just seems to not be operating as intended. Anyway, I replicated what you did and it half works…but adding another instance at the end resolves it, so in the end, two functioning workarounds in this thread. I had to split this video into 2 parts due to file size…Again, thanks for your help.

A third option, draw an edge on the image, select the edge and the image and make component including the always face. Then open the component and delete the edge.
This will give you an image within a component that will have both the component properties and the Image properties, such as no edges and remains visible when editing other things.


My solution was at the end of a long day, also messing up rotating your component’s axes. In the end I reverted to the basics of creating a ‘Always Face camera’ (Red on base line / Green perpendicular away / Blue up).
But the truth is that @Box was solving your issue much faster.
And as for importing a .png, SketchUp aligns the image to the face you put it on (you are pointing to), or to the ground plane or a vertical G/B or R/B plane. The first option makes the image a ‘Glue to’ image. the second one is a free floating image. You never get the option to make it a component right away, (unless maybe in the latest SketchUp version).

I would go for @Box’s first video solution to quickly adjust your component to be the correctly aligned ‘Always Face camera’ component.

I shouldn’t work that late.

1 Like