A problem with orbit

sketchup
help

#1

Hi guys,
when I orbit in sketchup make, most of the time all my objects I have built orbit with me and start rotating and keeping pace with my orbit, which messes up other structures that don’t do that and also doesn’t allow me to look at my structure properly. does anyone know a fix to that? or is there something I’m doing wrong?


#2

Do you have (many) ‘Face the Camera’ components in your model? Tthat might explain objects following (facing) you when orbiting.


#3

I’m not really sure, I’m an amateur with sketchup. could you tell me to how to change it if I do and I can make adjustments.


#4

Upload your SKP file and we’ll be able to tell you for sure AND show you how to fix it.


#5

thing.skp (441.8 KB)

all you need to do after you open the file is orbit it and the whole super market should move except one of the solar panels xD


#6

Normal geometry shouldn’t move when orbiting. As you can see, the base line of the supermarket stays parallel to the bottom of your screen. It is a ‘Always Face Camera’ component, following the viewer of the screen, thus you.
You could alter its properties in the ‘In Model’ component library: disable ‘Always Face Camera’.
Read about this subject in the help articles.


#7

Everything except the panel with the diagonal areas is in a single Component named “Chris”. From the description on that Component in the Components Window, it would appear that you started with the Component for Chris Dizon (possibly pre-loaded in your Template) and edited it to replace its contents with the rest of your building! Since the original Chris had the “Always Face Camera” behavior set, so does your version! It would be better to delete Chris (if you don’t need him for scale) and create your own new component!

To turn off the behavior, open the Components window, select Chris then Edit, and uncheck “Always Face Camera”.


#8

so how would I delete the ‘chris’ component?


#9

In the view, click on it then hit the delete key. To remove it entirely from the model, after deleting the instance(s) in the view, do Model Info->Statistics->Purge Unused. If Chris keeps coming back in every new model you open, open a new (blank) model, delete Chris per the above, then do File->Save As Template. Be sure to click the “use as default” so you will get this Chris-less version next time too.


#10

if any of you guys could delete it for me and send me the file, that would be great. I still cant figure it out ;-;


#11

Right click on it and select explode, then while it is all still selected, right click and Make Component.


#12

thanks
<3


#13

This topic was automatically closed after 91 days. New replies are no longer allowed.