Running SketchUp 2017 Via VPN Launching Issues

I just updated to Sketchup 2017 and I have run into an issue. I often work remotely and need to connect to my Desktop in my office via a VPN line. I have never had an issue running previous versions of SketchUp while operating remotely. I tried to do this today with 2017 and received a start up error.

"The following errors were found when launching SketchUp:
- Hardware acceleration is unsupported or has been disabled on your graphics card. SketchUp requires that you use a hardware accelerated graphics card.
_Unfortunately, these errors will prevent SketchUp from running. Updating your graphics card drivers might fix the problem. _
See this Help Center article for more information."

I have a relatively new BOXX machine with an Nvidia GeForce GTX 980 Ti Graphics Card. I am not sure what is causing this issue. The program works fine if I try to run it locally on this machine, why wouldn’t it run via the VPN pipeline? Any help would be greatly appreciated.

I expect you are running into a problem because you’re not using the graphics card in your desktop machine when you are running over VPN. In the past, SketchUp would just use the CPU for processing but with SU2017, that’s no longer an option.

You might read up on graphics over VPN.

If you need to access your models remotely, you might consider uploading them to Trimble Connect and use my.SketchUp. It’s not as full-featured as the desktop version of SketchUp but it can do quite a lot.

1 Like

There is something a little unclear in your description. Are you running SketchUp on your local machine while you are VPN connected to your office network? Or are you running SketchUp on your local machine while remote controlling your office computer, that is not running SketchUp? Or are you remote controlling your office computer, and that’s the one that is running SketchUp, and your local machine is not running SketchUp?

I am using my laptop from my home to connect to my desktop in my office through a VPN line. While doing this, I tried to start SketchUp on my office computer. That is when I received the message. While I was in the office yesterday I was able to run SketchUp on that machine without any problem. I am also able to run SketchUp on my home machine without any problem. Does that make sense?

Thank you for your response Dave. I always thought that when you open a program remotely it uses the host computers Hardware. Am I mistaken in thinking that? Maybe I’m misunderstanding how operating through a remote desktop connection works.

I did a little reading on VPNs and graphics–most of it was gaming related–and the information indicated that the processing that the application needs is done by the CPU and not the GPU. And I suppose since you aren’t running SketchUp locally, it wouldn’t use the local GPU.

It definitely should use the office computer’s video, you’re just screen sharing. But, maybe that part is demanding, enough to not let the video hardware acceleration kick in.

In your VPN client do you have settings where you can say what video quality is used? Perhaps setting that to a lower amount would give the office machine more video memory for SketchUp.

Would be interesting to open SketchUp before you go home, and see if you can then connect without SketchUp complaining.

I will try the latter some time next week Collin. Luckily I have SketchUp on my home machine and I can still access my files that are in the office. Sometimes I need to open up files while I’m working remotely on the office machine so I was testing that out being that I just upgraded to 2017. I’d rather find out now while I’m in a slow time at work than find out when I’m in the middle of a project in the middle of the night.

There should be no way that my work machine is taxed out of resources. Often 2 to 3 versions of 3D Studio Max while running 6 - 10 versions of SketchUp also using illustrator and Photoshop with multiple files open all at the same time.

This isn’t a VPN issue; it’s a Remote Desktop issue. Unlike previous versions, Sketchup 2017 checks and strictly enforces you are using a compatible video card and driver at startup. When using RD, the host is not using its hardware video card or driver. It is using RD-specific software driver which does not pass the Sketchup test for hardware acceleration. There may be ways to trick Sketchup into thinking the RD session is using compatible drivers, but I suspect this will be rather involved (I will be investigating).

This is a problem for me. I use Sketchup at home and at work; one is Windows and the other is Mac. All my files are stored on Dropbox and I’ve never had any cross-platform issues with models (kudos to the Sketchup devs). I don’t do hardcore design over remote desktop, but it is convenient.

Example use case I ran into today: I set up a few additional keyboard shortcuts on my Windows box last night. I hadn’t exported them; I am just adding the same ones on my Mac. I wanted double check I set up the same keys so I used remote desktop to check my Windows box. Sketchup fails with the hardware acceleration error. In this case, I don’t care if video performance is degraded, even severely, I just want to get into Sketchup.

There are many other 3rd-party remote desktop/VNC solutions available, some of which may be configurable to get around this error. But I’ve found them all to be far less robust and less reliable than the native RDP implementation; and it’s not worth it for me to test all of these simply to avoid this problem.

I use Remotix for remote controlling my Mac sometimes. It has no trouble opening SketchUp, but maybe the hardware test on Mac is different?

I had an opportunity to test a Nvidia Grid and Citrix based remote desktop system, and it ran SketchUp without problems. Haven’t tested v.2017, the version was 2015 if I remember right.

Anssi

Workaround: Start Sketchup on the host computer and leave it running. Sketchup 2017 will then work remotely via Remote Desktop. This is presumably because they only perform the video card check when the program starts.

Re: other questions about configs: Yes, other operating systems and remote/VNC software can produce varied results. I’m only speaking about connecting to a Windows machine using the Microsoft Remote Desktop client software. (Note: The client operating system is not important here. I regularly connect to my remote Windows machine using both Mac and PC.)

2 Likes

Thanks for the help. This definitely works. By leaving it on everything works. I have found that you have to do it with both SketchUp and Layout if you want to use them both. It is frustrating when I do forget to leave them on, more so when the IT staff pushes an update that restarts my computer at work. At least I know what the issue is now.

Thanks again

If you forget to start the program before you leave, and need to make it run, the easiest way I have found to start a program remotely that requires some sort of check is to run a simple batch program.
You are essentially disconnecting from Remote Desktop, starting the program automatically, and then when you reconnect the program will have opened as if you were sitting in front of the computer yourself.
Note: To do this, you need administrative rights on the computer (able to click “Run as Administrator”)

tscon 1 /dest:console
start "" "FULL DIRECTORY NAME TO PROGRAM"

The tscon command disconnects you from RDP and switches the computer to the “console” so the computer unlocks itself (when using RDP normally, the regular monitor the computer is connected to is locked).
The start command then starts Sketchup after it disconnects, and since the computer is running as if you were in front of it, the system passes all the required checks.

So if I had the SketchUp 2017 shortcut on my desktop, my code would be:

tscon 1 /dest:console
start "" "C:\User\Eric\Desktop\Sketchup 2017"

To make this work, create a new text file; type the code in, and save the file. To save it as a batch file, you have to be able to change the file extension, so if you can see the “.txt” at the end of the file, you can skip this next part.
Search " File Explorer Options" in the windows search bar, click the first option. After the window pops up, click the “view” tab and uncheck the box "Hide extensions for known file types. Click apply and close the window.
Next, go to your text file with the code in it, right click on it and rename the file to a name with the extension “.bat” (example: “RemoteStartSketchup.bat”).
Now it’s all set up; if you want to use it, just right click on the batch file and click “Run as Administrator.” You will be disconnected, and then once you reconnect SketchUp 2017 will be open.

I have noticed, sometimes windows changes what session ID is used, so the “1” in “tscon 1 /dest:console” may need to be changed.
To find the correct ID, search “cmd” in the windows search bar, and type “query session” after the black window opens. Then replace the “1” with whatever number is in the “ID” column on whatever row there is a “>” marker in on the left side. See the image below, my current session ID is “4.”

I created a script to figure out the session ID automatically; here is the new code:

for /F "tokens=1,2,3,4,5" %%A in ('"query session | find "Active""') DO ( tscon %%C /dest:console)
start "" "C:\Users\Eric\Desktop\SketchUp 2017"
2 Likes

This does not make sense (sorry.) The local screen (graphics) might be quite different than the remote graphics where the remote application is running. It is unlikely that the local machine (being used as a terminal,) can directly access the remote machine’s GPU or GRAM.

It makes more sense that the interface is using a virtual machine (ie, an emulator.)
After All, the “V” in VPN means “virtual”.

Thank you Dan. It is definitely a virtual machine thing. What I don’t understand is that I never had this problem with previous versions of sketchup. Only when I switched to the new 64bit version have I started having the problem. The new software has obviously changed the way it uses resources in regards to using VPN files. I used to be able to remote in from my phone and do a quick edit. Now, the only way I can use sketchup is if I leave it open on the work desktop. For some reason, if it is already active I can remote in and use the software. The issue arises when I want to open a new window of sketchup. That is when it say it cannot open it. I hope this is something the software team can work out. I see no reason it should be happening. My machine a brand new BOXX machine and shouldn’t have any problem with resources.

Because SU2017 overhauled it’s graphics pipeline to OpenGL v3.x, and no longer will run with hardware acceleration disabled, aka CPU rendering. More specifically, SU2017 now only supports GPU rendering.

And BTW, I believe SketchUp has never supported VPNs or running in emulators:

The SketchUp Hardware and Software Requirements page:

Virtualized Environments
At this time, SketchUp doesn’t support operation in a virtualized environments such as VMWare or Citrix.
Per the SketchUp Pro License in section 1.1:
You may not use or host the Software in a virtual server environment.

Boot Camp/Parallels/VMWare
Neither Boot Camp, VMWare nor Parallels are supported environments.

Remote Desktop Connections
Due to hardware restrictions in shared environments we can’t reliably predict how SketchUp will perform. At this time SketchUp is not supported via a Remote Desktop Connection (RDC) on any platform.


Don’t hold your breath. They have decided to go the my.sketchup.com with Trimble Connect route instead.

That is true. Regardless, I have tested it successfully in a virtual machine that runs on a server with a Nvidia Grid graphics solution that makes the VM think it has a Nvidia Quadro card. But the more common virtual machine platforms or the standard Windows Remote Desktop do not suppport OpenGL.

Anssi

1 Like

Yes, there is as always a difference between supported and will run. For example, up through SU 2016 I can run SketchUp on Parallels VM on my Mac (I can’t run 2017 only because Parallels doesn’t support OpenGL 3.0). But I don’t expect any help or support from Trimble setting it up or if I run into issues…