Sketchup in Virtual Box Windows 10 Guest

I prefer running Linux (Ubuntu 16.04 LTS) on my home computers for security purposes. Sketchup will only run on Windows. I set up a Virtual Box on Linux to run Windows 10 and have been running Sketchup 2016 quite successfully. However, the 2017 version will not run. I get this error:
"Hardware acceleration is unsupported or has been disabled on your graphics card. Sketchup requires that you use a hardware accelerated graphics card."
It appears that the system requirements for 2017 have become more “picky” and is generating this error.
Is anyone else running Sketchup in Virtual Box and have any advice on how to handle this error?

I know for a fact that Trimble upped the ante for OpenGL support in SU 2017. They did this to enable their new rendering pipeline that makes 2017 faster than 2016 on many things. SU now tests for the required OpenGL features on launch and refuses to run if they are not supported.

The problem then comes down to how OpenGL is implemented in Virtual Box. It is possible that it doesn’t provide the features SU now needs (e.g. the Parallels VM on Mac can’t run SU 2017 on Windows because it is still at OpenGL 2.1). There is nothing SU can do about such situations; users will have to petition the VM supplier to update their OpenGL libraries.

It is also possible that when probed, VirtualBox reports an OpenGL string that SU can’t understand. That might be fixable within SU, but since VM’s aren’t officially supported in any case it seems likely that Trimble won’t do anything about it.

1 Like

Not quite. There are virtualized environments that are geared to running software that demand high-end graphics, like the Nvidia Grid. Tried it once - SketchUp 2015 ran like a charm with HW acceleration enabled.

Anssi

I’m quibbling, but saying that VM’s are not supported is different from saying they won’t work.

2 Likes

I also opened a forum question on the Virtual Box site about this. Can
you tell me what version of OpenGL SU 2017 is now using?

Excellent! Thanks for the pointer.
I ran the utility and sent the log file to the Virtual Box people I’ve been talking with. I attached it here in case you want to see what it said.
SketchUpLogFile.pdf (32.8 KB)

It will be interesting to see how they respond! That log shows that their driver currently doesn’t respond the way SU expects to virtually all of its OpenGL probes!

I am also perhaps nitpicking and playing the devil’s advocate, but I started to wonder that if Bootcamp, VMWare and Parallels are specifically excluded, it might mean that others, like Citrix, are supported…

Then there is my.sketchup that is basically also Sketchup running in a virtualized environment.

Anssi

SU 2017 requires a graphics card that supports OpenGL 3.0 or greater.

Some virtualized environments report their own unique OpenGL versions/strings. VMware Workstation, for example, returns an OpenGL version of 3.0 even though the host machine’s graphics card supports OpenGL 4.4.

Virtualized environments are not supported for SU 2017 (Mac or Win).

Bootcamp actually boots a Windows system on Mac hardware, it is not a VM at all, so it will not be excluded unless the Windows version you boot and its drivers lack adequate OpenGL support.

I believe VMWare Fusion already supports OpenGL 3.0. I haven’t heard reports that SU 2017 won’t run on it. Have you?

Parallels can’t run SU 2017 because Parallels does not support OpenGL 3.0 as yet, only 2.1. This is a Parallels issue, not a specific targeting by SU.

So, there are no known exclusions of specific VMs as such, just enforcement of the need for OpenGL 3.0. You have created a strawman that won’t stand!

So, have you heard if VMWare Workstation Player runs SU 2017?

I recently retired from HP as an IT Solution Architect. I am doing volunteer work with the local school, library and other venues to bring awareness of advanced technology to people who would not otherwise be aware of them. I have used SU to design (and build) my house, to design wheelchair ramps for a volunteer organization and for my personal woodworking projects. I love it! I think it’s a great CAD tool (since it’s free!) to use to introduce students to the wonderful world of 3D CAD. However, I’m very sensitive to security issues and use Linux on my personal computer for practically everything. I was jazzed to find that I could run SU in VB on my Linux system. With the latest version of SU not working on VB however, that was a real bummer. So, if VMWare can possibly run it I’m going to give it a try.

BTW, if there are any SU mucky-mucks listening:
PLEASE! Port SU to Linux!!! I think you will be amazed at the audience that will use this!

I just installed VMWare Workstation Player latest version (12.5.1). I created a Win10 VM and booted it up. I got a 3D graphics acceleration error that was fixed by following instructions on this link.

I installed SU 2017 and it runs! I’m in the process of opening some 2016 SU files, applying keyboard shortcuts, etc. If I run into any trouble, I’ll report back.

Hi,

I am having the same problem. I want to install Sketchup 2017 on my VirtualBox Windows 10 Guest System. There I have OpenGL 1.1.

Is there meanwhile a posibility to install it on the Guest System?

VMware Workstation Player v12.5 f. Win x64 & Tux x64

You need at least OpenGL v 3.0 for SU 2017. So unless you can install something to give you at least that, you are out of luck. Is there a separate
toolbox in VirtualBox as there is on VMware and Parallels? If you haven’t installed it, try that.

Check the OpenGL hardware requirements for earlier versions of SU. You might get one of them to run, if necessary by turning off Use hardware acceleration (not an option in v2017).

Or see if VMware will install instead of VirtualBox. I believe it can support OpenGL 3 or better. Parallels on Mac will get you only v2.1.

nope.

SU v2016 (and older): OpenGL v2.0

OpenGL v3.3 since VMware v12.0 (2015)

This is the answer from virtualbox forum:
"VirtualBox does not provide an OpenGL 3.x API for Windows guests, only for Linux. In Windows the graphics API provided will be DirectX.

If you install the GAs in safe mode then you can have OpenGL 2.1 at best. Otherwise software must use DirectX."

Is Sketchup 2017 running under Linux?

No. Windows or Mac only.

As I reported in an earlier post, I have been running SU in VMWare Player on a Linux (Ubuntu) host since last November. It works great!
Forget VirtualBox. They are really behind the curve in support OpenGL (which SU needs).

I thought, that VMWare isn’t a free software or can I use it also with windows 10?

Or is it possible to use it only with a sandbox, so I haven’t to install a hole windows system?