Anyone using SketchUp in a virtual machine on Mac?

I was curious if anyone out there is successfully using SketchUp 2017-2019 in a virtual machine on Mac.

I’m trying to test out some extensions in Catalina (installed in the virtual machine) and I keep running into this:

image

I have set VMware Fusion to use full hardware acceleration for video and it’s still not working… I think it was something to with how VMware emulates a video card?

Has anyone else seen this? And if so, is there a solution?

There are a number of threads on this topic, Eric. Here’s one I just dredged up.

1 Like

Hi Dave!!

Yeah, I saw that thread too…

It looks like SketchUp requires open GL 3.0 and higher, and VM ware Fusion supports OpenGL 3.3:

VM ware Fusion:

My guess, and this is only a guess, is that the “virtual graphics card” that VM ware Fusion makes just doesn’t play well with SketchUp. I realize that this is not supported, I was just curious if anyone has found a workaround for VM ware Fusion or some other virtual environment…

I haven’t tried VMware Fusion, but I’ve had success running SketchUp under Parallels Desktop 15 on my Mac with Catalina.

Really! Ok, I’m going to have to give that a shot…

@slbaumgartner I got Parallels running, but I’m still getting that graphics card error. I googled around and changed some settings on both my Mac and Parallels to make sure that as best as I can tell my real graphics card is being used…

Is there something obvious I’m missing here?

I use bootcamp, which does recognize the card.(even Enscape is running, sort of)
With SSD, it is not so time consuming.

1 Like

Eric - What are your Mac stats? I’ve had no problems running SU v 2018 and 2019 in Windows using Parallels 14 and Windows 10. I have an iMac Pro running Mojave with a Radeon Pro Vega 64 16 GB card.

I have no problem either, but I thought he wanted to run SketchUp in Catalina, running in a virtual machine. Not Windows.

To test things in Catalina it might be easier to install it onto an external drive that you can boot from.

This is the Mac I’m currently running Parallels on:

image

Should be more than enough horsepower to run SketchUp in VMWare/Parallels with Mojave… I mean, it does run just fine, I just can’t get SketchUp to recognize my graphics card! :slight_smile:

I had been doing this same thing years ago, I’d always “upgrade” to the latest MacOs on my VM, test the plugins that I make, then upgrade my main machine…

Ok, I finally solved this…

Parallels and VM Ware Fusion support OpenGL for SketchUp in WINDOWS, not any version of MacOs, so as of now you cannot run SketchUp 2017 and later in a VM using either one of these. I ended up making a bootable drive with Catalina on it and installing SketchUp on it to test. More work than I wanted, but in the end it solved my problem.

1 Like

Yes, external drive Catalina is what I was suggesting. Or, just use Catalina.

Yeah, I’ll eventually get to Catalina… I just want to be able to jump back and forth between the two for testing…

Besides the bootcamp drive, for support issues I still have a Mojave bootable on my iMac, but it does not have a ssd, so it would take a little more time.

Mike, have you run into any issues running SU on Windows via BootCamp? Do you have any comparable experience with Parallels/VMWare?

(Sorry if this is slightly OT)

I used parallels to mimic windows for my son, who wanted to play games, but found out that the support for direct x didn’ t work.
Ended up with bootcamp, instead.
That machine did not have a SSD, though.
When it comes to graphics, there is no way to simulate hardware-specific issues, I guess. It is just to complicated (downloads of drivers exceeding 400~500MB-so much text!)and there are so many.
I left Parallels and split up:)

1 Like