OpenGL in Windows 7 under VMware in Linux

I’m using a Lenovo Thinkpad with 8gb of memory and an i5 processor. It dual boots Windows 10 and Linux. I use Linux 99% of the time. Within Linux I have VMWare with a Windows 7 guest and with VMWare tools loaded.
If I run Sketchup ver 2018 in the Windows 10 installation it runs just fine and the checkup app indicates that all hardware and software requirements are met. If I try to run Sketchup 2018 in the Windows 7 guest installation, it will not run giving the typical message about needing OpenGL 3.0 or higher. The Checkup app also fails.
I am trying to figure out why Sketchup 2018 runs in Windows 10 but not in the Windows 7 guest. Is it due to limitations in Windows 7 or in VMWare or both? Is there a way to fix it?
BTW, I can also run the web version in Firefox in the Windows 7 guest. I think I read somewhere that this version also requires OpenGL 3.0.

Probably it is due to OpenGL limitations in your VMWare installation. I can run SketchUp 2018 and 2019 OK in my old Windows 7 computer.
Googling about VMWare and OpenGL I found this forum thread: https://communities.vmware.com/thread/579259

Thanks for the info. I’ve seen the link you provided and it deals with someone that has a dedicated graphics card which I don’t have. Mine is integrated. It seems to make a big difference. Does your Windows computer have dedicated or integrated graphics?

I think I read somewhere that the web version also requires OpenGL 3.0 or higher. I could be mistaken. I can’t find what I think I read to verify. Is it true?

Integrated graphics is not the best solution and not recommended. A dedicated GPU from Nvidia seem to work the best.

The answer is that I did not have Vmware Tools installed as I thought I did. Once that was done, everything works just fine. Sketchup vers 2017 and 2018 are happy with the system capabilities and run as they should. I’m happy!

1 Like