RTX 2080 Ti with Sketchup 2016 - Hardware Acceleration Not Working

opengl

#1

I’ve been saving up for new upgrades for a very long time (new Sketchup and all new plugins, new graphics card and a new screen). The RTX cards were unexpectedly higher than the prior generation so I possibly incorrectly chose to spend my upgrade budget on just the RTX card. Unfortunately I’m having some problems with Sketchup.

Sketchup doesn’t seem to detect it, or at least its capabilities. When I select “use hardware acceleration” the openGL details are blank and no AA is available.

I’ve tried every available RTX driver. I’ve done a fresh install of Windows with an Nvidia “clean” install of drivers between each attempt. I’ve made some changes to the Nvidia control panel to force the 2080 as the default OpenGL device and tried to make Sketchup allow it to make applications based choices, even tried overriding it to use the global defaults. I made sure my onboard graphics was disabled (i7 8700K, no monitors plugged into the onboard ports and bios set to use PCIE slot as the default, no onboard shown in device manager).

I know I need to upgrade SketchUp at some point but honestly I’ll be broke for a bit after buying the 2080. With some of the plugins I use it’s an all or nothing deal as well. I know my buying decisions and cash flow aren’t your problem, it’s just that buying the latest version isn’t a fix for me right now due to money. I know this is totally a first world problem and I’m sure there’s not a lot of pity for someone who just bought an overly priced RTX 2080. I’m really hoping there’s another option is all, especially because software rendering on the models I’m using is exceedingly painful.

Happy Holidays all!


#2

As a test and to eliminate the fact its’s a 2016 issue, have you downloaded a trial of Pro2018?

If that also fails, then at least you know it’s something else. I would think it’s probably fine (as in you should be able to fix it).

I have two new RTX cards on the way but before I ordered it I used a demo machine and it was working with SketchUp no problem. I had 2017 Make and 2018 Pro when testing.