Ram issues on MacBook Pro New User

2017

#1

I am running a new MacBook Pro with 16gb ram and having nightmares with ram usage.

With just SU running the ram usage on the cpu is gong to max then crashing within a few minutes of starting the software.

I did have a space navigator recommended to me but after functionality issues decided to not use it. I have read posts about this being the issue but can’t seem to remove all the drivers or I’m not doing it right as the problem is still there.

Trying to do extensive learning cycle of Christmas so this has rather stunted progress.

Any help to get back on a level playing field appreciated.


#2

Oh, this can be frustrating if you had been looking forward to benefit from the holiday time for some projects.

First we need to distinguish whether your model just uses a lot of resources (there are settings and workflows to reduce resource usage) or whether it is a memory leak (bug), e.g. an application or driver allocates memory but never frees it and continuously memory usage rises. This can be detected by keeping an application open for a long time (and doing nothing or only trivial stuff on a simple model) and observing whether memory consumption rises linearly to a multiple of what it was before.

I would check that you have the latest version of the space navigator driver and SketchUp extension (for SketchUp 2017). If using the wrong (old) version with a newer version of SketchUp there can be instability, or memory leaks.


#3

I’ve dowloaded all the new drivers and installed and then un installed to try and ensure it’s all up to date


#4

If it sits idle the ram just gets totally used up in approx 3-4 minutes


#5

Interestingly none of the connections software would work like the tutorials etc. So I decided that the controller was a non starter. Really want to use it however as my colleague swears by them but he is using a Alienware pc.


#6

I had this problem earlier.

The uninstall from 3d connexion doesn’t remove everything.

Check there’s nothing left in:
~/Library/Application Support/Sketchup 2017/Sketchup/Plugins/
and also the system /Library as well as the user library - note, no tilde at beginning.
/Library/Application Support/Sketchup 2017/Sketchup/Plugins/

Do a global search for ‘connexion’ or it might be ‘3dconnexion’ too

See this thread:


#7

I go in applications and l have folders for SU2013 , 2014, 2015, 2016, 2017 and 2018…all had 3dx drivers in.

Don’t understand as this is a fresh Mac so how come so many old version support files.


#8

Look in both ~/Library and /Library locations for all SU versions


#9


#10

I have deleted the files in all copies and its sitting at this with SU running but now drawings open
seems excessive memory use to me


#11

Open Actvity Monitor which you’ll find in /Applications/Utilities
Click the Memory tab, then Click the “Memory” column header to sort in order of descending Memory use. This is to check that SketchUp really is the culprit and to see how much it is using.


#12

I sometimes see SketchUp’s memory use climbing without limit due to the Space Navigator. But on my Mac it only happens when the SN hardware is attached, and removing or renaming the extension’s 3DxSketchUp.rb file stops the problem completely.

As noted in a previous post, the 3DConnection installer creates folders in /Library/Application Support for all versions of SketchUp (even ones you don’t have installed) and installs its 3DxSketchUp.rb and associated extension folder in each of them. So, to turn it off you have to make sure you are looking in the folder for your specific SketchUp version. Entries in the folders for other versions won’t have any effect.

@McGordon is right too: you should verify that SketchUp is the actual culprit by using the Activity Monitor. Once that is proven, you should next try running SketchUp with all extensions disabled. If the problem doesn’t occur then, it is clearly an extension not SketchUp or your model per-se. Then you can re-enable extensions using your favorite strategy (one-by-one or half at a time) until the problem re-occurs. It is possible there is interference between multiple extensions that is causing the memory leak.


#13

with just sketch up running and safari it is showing a kernel task (un labelled taking over a gb of operating ram)


#14


#15

That is not unusual or a problem. The kernel_task normally takes about a gig. SketchUp’s 333MB is typical when a modest size model file is open (with a blank model I usually get on the order of 140MB or so - it varies). IF you watch for a while do the numbers grow?


#16

I would be more concerned that ‘CleanMyMac 3’ is always running, and trying to guess what it can optimise…

john


#17

I’ve not used CleanMyMac 3 but have the impression that it just seeks and cleans up “cruft” on your hard drive/SSD? It would be strange for that kind of operation to consume large amounts of RAM. But in any case, checking the Activity Monitor when the problem occurs will immediately reveal what app is the culprit!


#18

I’ve always used clean my Mac to keep on top of stuff. It also has a system monitor that tracks usage.

It can be disabled


#19

To be honest I’m pretty gutted that the space navigator seems a no no as I was looking to use sketch up in tandem with inventor packages we have running at our offices.

Sketch up for on the go stuff to them communicate back to the office

Everyone. Raves about the space navigator but it does seem to have problems with SU on the Mac


#20

Yes. And 3D Connection has notoriously failed to address the memory leak issue, which has been there for some years.

I like the Space Navigator enough that I cope with it. I find that if it is going to occur, the problem starts immediately when SketchUp is launched; I’ve never seen it once SketchUp has been running ok for a while. So when I launch SketchUp I watch the available memory for a few moments to see whether it starts falling (or that SketchUp starts growing in Activity Monitor). If it’s out of control, I kill SketchUp and try again.

On 2017 I found that if I immediately close the default blank model on startup, that will usually prevent the runaway. That doesn’t seem necessary on 2018; it runs away less often but it still happens.