SketchUp Make 2017 using up all my RAM

Since upgrading to Sketchup Make v.17.2 my memory (RAM) gets used up in less than 5 minutes. After launching and drawing a cube I observed Sketchup steadily increase its memory usage in Activity Monitor. I have removed all extensions and plugins, have no external mouse devices.
My Mac is more than capable to handle Sketchup. I just can’t figure out why its such a memory hog.

Can anyone tell me if this has been addressed as a bug or suggest a way

I’m using a 2016 MacBook Pro 15".
Processor Name: Intel Core i7
Processor Speed: 2.9 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 16 GB

Video Cards:
Intel HD Graphics 530:

Chipset Model: Intel HD Graphics 530
Type: GPU
Bus: Built-In
VRAM (Dynamic, Max): 1536 MB
Vendor: Intel (0x8086)
Device ID: 0x191b
Revision ID: 0x0006
Automatic Graphics Switching: Supported
gMux Version: 4.0.29 [3.2.8]
Metal: Supported

Radeon Pro 460:
Chipset Model: AMD Radeon Pro 460
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 4096 MB
Vendor: ATI (0x1002)
Device ID: 0x67ef
Revision ID: 0x00c0
ROM Revision: 113-C980AF-908
Automatic Graphics Switching: Supported
gMux Version: 4.0.29 [3.2.8]
EFI Driver Version: 01.00.908
Metal: Supported

3D Connexion products can cause this…

if you have one, search the threads for issues with it…


Thanks for the quick reply.

I’ve eliminated everything 3D Connexion and restarted. It worked.

Can you tell me if anyone has brought this up with 3D Connexion.

I would really like to get this resolved because I’ve been spoiled by my space navigator for several years now.

I’m going to give them a call either way to see if they are aware and what their plans are to resolve this issue

It has been brought up multiple times with 3D Connexion and they are both very slow to respond and, at least based on track record, incapable of finding and correcting their errors. They should, in my opinion, be really embarrassed at their lack of ability to deal with this problem that has been reported for several years across multiple versions of both SketchUp and OS X/macOS.

1 Like

Steve, are you still using yours…

I gave up again and now have a pair sitting in their boxes…

the wireless one seemed to be worse than the corded, but I’m not keen to loose another hard drive over either…


I was having good success with the technique of immediately closing the initial empty model, but lately I’ve been running without the navigator attached due to limited space (I’m away on vacation) and SketchUp has been running away with memory again. I need to kill off the driver to verify that’s what is doing it, as i also installed some other extensions too…

These guys don’t seem to give a shi* about SketchUp on mac (but then, Trimble has left numerous Mac issues untouched for years too).

Unplugging it just caused as much grief for me as having it on…

I disabled the plugin and App whenever I unplugged it…

when my first ‘ticket’ got escalated, they sent me excellent help notes…

for Windoze…


Perhaps you’re holding it wrong … try not to touch any of the metal parts. :wink:

I wish! Don’t even have to touch it at all :triumph:.

1 Like

I’ve been using Macs and Space Navigator for quite a few years and have never experienced the memory drain problem until I installed MacOS Sierra 10.12.5.

This morning I backed up my computer and used CleanMyMac 3 to uninstall SketchUp and 3Dconnexion. I then checked for and trashed any residual files in User Preferences and Application Support folders.

I also found in (Macintosh HD>Library> Application Support) folders for SketchUp 13, 14, 15, 16, 17.
Inside those folder were files and plugins named 3DxSketchUp. I trashed them all. Emptied the trash and restarted my Mac.

Reinstalled SketchUp.

I added all my SketchUp plugins and extensions and customized it to my liking. I opened a new file and one that had also been known to accelerate memory drain. Activity Monitor showed no sign of increased memory usage.

I then downloaded 3dConnexxion’s latest Mac driver, installed it and restarted. Before launching SketchUp I went into System Preferences>3Dconnexion and selected the configuration for SketchUp.

I reset all my SketchUp preferences and for a few hours I have been opening new and old SketchUp files. I’ve been modifying and saving large models all the while checking the Activity Monitor.

I have not had any significant memory drain. Memory stabilized at just under 500mb. for the largest SketchUp files.

So, here is my theory: Somewhere the 3Dconnexion driver(s) got corrupted and within SketchUp accelerated memory usage until it eventually affected active applications.

I’m thinking (for me) the corruption happened as a result of system software update or from an upgrade to SketchUp 17

So far, after several restarts and having opened a half dozen applications along with continually using SketchUp with my wired Space Navigator, my memory drainage has stopped.

BTW I have trashed, with no adverse effects, all the old SketchUp folders containing 3DxSketchUp files and plugins.

Please let me know if anyone has duplicated my procedure with success.

Alas, I installed the 3D connection driver and SketchUp extension after my last system or SketchUp update and as reported I’m getting the runaway memory issue. Something is funky still…

the procedure YES, successfully for more than a few days NO…

the root of the issue seems to be if you ‘ever’ unplug it, or it thinks you’ve unplugged it…

I’ve tried 5 driver versions to date, each proclaiming a fix…


No Mac here, check of the admin tools flag some 3D x possible driver issues and windows could not find any update. If you have admin tools in your control panel my want to check what it is reporting. The Windows system has a number of performance monitoring setups possible and the results are written to log files, RAM memory use may be improper setup use of paging files. Just some thoughts it will take me some time to understand what is going one with the Windows Performance monitoring.
I have not had the problem , ?? but, still on w7

I also had that problem in the past. But all is ok now.
Having the latest driver.
3Dx rb files in only one spot. Deleted all the others.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.