Mac OSX Sierra Crash


#1

Running Sketchup Make 2017 on my MacBook Pro using OS X Sierra the computer freezes after about 15 minutes of working on a Sketchup model. The message I receive is there is not enough application memory, close unnecessary programs. I’ve only been able to force close Sketchup and loose my work. I had no problems with Sketchup 2016. Do I need to revert back to it? I really prefer the improvements in 2017.


#2

That’s quite unusual, as Mac OS X uses virtual memory, meaning that it swaps memory contents to disk when the RAM fills up. How large are your models? How close to full is your disk? If there is insufficient space left for the swap file (like only a few GB), that could be your problem.


#3

or you have a runaway driver for a Space Mouse?

or maybe an overzealous Render Extension and/or massive materials…

does it happen on all models?

john


#4

Hello, thanks for both your questions. My model is 480KB; I’ve been working with models in Sketchup 2016 as large as 24MB with no problems. I’m using less than 10 percent of the space on my disk and I have 500 GB of flash storage.

I’ve only started the one model on Sketchup 2017.


#5

John, thanks for responding. I THINK I’ve fixed it by reloading OS Sierra and SketchUp 17. It’s been working for a couple of days now.


#6

I am having the same issue with SU17 on macOS Sierra. It crashes after running out of application memory. I ran the Activity Monitor and discovered that SU17 was using 100% CPU and 15.5GB RAM. My Macbook has 16GB RAM. This was after having downloaded and installed the latest SU17 available on the web site as of 12/27/16.

In comparison, I ran SU16. CPU utilization was about 50% and memory consumed was around 8GB.

I will have to redo a lot of work in SU16 until the issues with SU17 are fixed.


#7

I was able to resolve this issue by first reloading the new Sierra update, then loading the new sketchup 17 update, then loading the update for my 3D Connexion space mouse. I’m not sure which update really solved the problem. Hope this helps.


#8

The 3D connection mouse driver is the most likely culprit. There have been other reports of it running astray until updated to the latest version.


#9

I think you’re right Steve, unfortunately I spoke too soon, the Mac froze up again today. I’ve removed the 3D mouse software, hope that’s the end of it. Thanks for your help.


#10

It might not be, depending on how and where you removed the 3D connexion software from.

I found leftovers from a 3Dconnexion CADmouse installation in /Library/Application Support/Sketchup 2016/Sketchup/Plugins which were NOT removed by uninstalling in the usual way - note that starts /Library NOT the usual ~/Library for the user’s folder, but a system-wide folder.

It ran away with memory at the rate of several gigabytes a minute.


#11

John, thank you so much, I did find 3D Con plugin files and deleted them all. One Apple guy told me to do this but didn’t explain the path to find the files. Your path info made it easy. Happy New Year.


#12

Hi, Methinks, from reading this thread that the ‘lack of application memory’ is being caused by the 3D Space mouse software, or what is left of it. I just handed in my MacBook Pro (late 2011) to the Apple fundi to assess what is wrong with the machine. Fearing issues around loading SU2017, I have been holding off using the latest version (I upgraded the DAY it was release!) until I was near some serious support (Now in Cape Town, otherwise on live on a remote island). Anyway, my worst fears were realised when this MacBook Pro completely froze up with no other software or OS working properly. Bought a new MacBook Pro (16MB RAM, 256SSD, 2,2 gHz Processor, 1TB graphics memory) and it is DOING THE SAME THING!!! I obviously restored from my previous computer with all the same settings, and on closer inspection am finding some bits and pieces from the 3D Space mouse - which would appear to be the culprit in this. Firstly, I would need confirmation that this problem does NOT occur where there is no 3D Space Mouse software uploaded, or is there an issue with SU 2017 loaded on Macs. Thanks


#13

I’m the original poster, that 3d space mouse is leathal to a MAC, my 2 macs are working fine now with


#14

If you didn’t follow these two steps be sure and do it, it should get you cleaned up. Never use that mouse again, also, I got rid of my Logitech 3 button mouse software too. I’ve gotten use to using my track pad and keyboard. Sometimes I’ll use the apply magic mouse. In addition to following the directions from “J” below, another user told me you could find further hidden files using the ruby counsel.


#15

I red this post just in time, last thing I did this night was to plug my 3d conn in order to install it tomorrow with the hope that the last driver could work with sierra/su17 on my iMac, but I think is not good idea.

Tom4 could you update the link from "J"s direction.

There is someone working with no problem with 3D Conn/Mac?

Tks


#16

Good Luck to them, Mine worked for about a week but the problem slowly started coming on. In the end I would crash within a few minutes. I’d love to use the 3d mouse, I paid for it, but I’ll have to wait and see more good results from others. As I said, learning to use the keyboard and shortcut keys has become fairly easy for me, it also allows me to use my laptop anywhere and work on Sketchup. Thanks for letting me know.


#17

Question:
Is anyone with a Mac and 3Dconnextion Mouse seeing an issue with running out of application memory, consistently?

Here’s how to check if you are seeing a memory leak…

  1. Launch SketchUp
  2. Make sure the 3DxSketchUp extension is running by going into SketchUp > Window > Extension Manager and making sure 3DxSketchUp is “Enabled”
  3. Launch Activity Monitor by hitting Command-Space on your keyboard and begin typing “Activity Monitor”, it should pop up, then hit enter.
  4. Click on the Memory Tab at the top of the Activity Monitor and highlight SketchUp… Keep an eye on the memory used. If it is climbing past 1GB, at a pretty good clip, then that’s great! Er… great for me. You are a candidate.
  5. If you wouldn’t mind, respond in this thread with the version of SketchUp you are using (Pro 2018 is an example) and your OSX version (like 10.12.6 for instance)

If it is a consistent issue, I’d like to put you on the remote access list. We are collecting data on the memory leak with the help of 3DConnexion to try to solve this issue.


#18

It happens to me most of the time, even after installing their 10.6.0 driver.

SketchUp 18.0.16976 on macOS 10.13.6. mid-2012 MacBook Pro Retina 15.


#19

Do you think you would be able to predictably recreate the memory leak scenario? How high have you seen it go? More than 2gb? We are looking for volunteers who can predictably reproduce the significant memory leak scenario and are willing to allow a tech to remotely connect to the system to evaluate the issue. It won’t happen very soon, because we are conducting some tests in house, but if those fail we may be looking for outside help in observing and troubleshooting this issue.
Thanks!


#20

I can get it to happen almost every time unless I do my workaround of very quickly closing the default model window before extensions finish loading (I don’t know what is different about conditions when it occasionally stays stable though I think it may be somehow related to mouse cursor movement). I have seen it go high enough that my computer becomes completely locked up (I have only 8GB of RAM). I can see it pass 2GB before it locks up, but once it locks nothing responds except glacially slowly. It usually takes macOS almost a minute to force quit SketchUp!

If needed, I’d be willing to cooperate with remote tech, as I have been complaining about this issue ever since I got my Space Navigator.