Sketchup causing Mac to lock up


#1

Hi All,

Having a major issue with Sketchup causing my iMac to lock up. From the moment I activate SU, the Activity Monitor shows the Memory pressure heading towards the red. Swap memory starts climbing as well, and within a few moments the spinning rainbow wheel kicks in and it just gets worse and worse for a minute until everything locks up. Even trying to close SU at that point can take more than 5 minutes.

I tried restarting the computer and running Clean My Mac, which gets everything else working again, but makes no difference to SU.

The problem occurs even when there are no other apps running, and with only a new blank model open.

Set up as follows:
iMac Retina 4K 21.5 (late 2015), 3.1 GHz Intel Core i5, 8GB 1867 MHz DDR3, Intel Iris Pro Graphics 6200 1536 MB, OS High Sierra 10.13.4, Sketchup Pro 2018 18.0.16976.
I am also running a BenQ GW2270 Monitor off a Thunderbolt port, and a 3D connexion mouse.

I am currently in a state when I simply cannot open SU without causing this issue.

Sketchup used to run like a dream on this system, but now I can’t run it at all.

Please help.

Regards, Andrew Vivian


#2

Your problem is most likely the 3DConnection mouse. There are known issues (very longstanding) with their drivers on Mac that cause SketchUp to endlessly gobble up memory until it freezes or crashes your machine.

Here’s the workaround that has worked reliably for me:

The instant you launch SketchUp, even before the extensions are finished loading, move the mouse to the upper left corner of the default blank model window and click the close window icon. Wait until all extensions have loaded and then open either an existing or a new file. I’ve found that on my Mac if I am quick on the trigger, the initial memory for SketchUp is about 150MB and it doesn’t increase until I open a file. If I am even a little bit late, the memory starts to soar immediately.


#3

Hi slbaumgartner,

Thank you for your prompt response. A couple of follow up questions.
I was thinking I could test your theory by unplugging the mouse, but if it is due to the drivers, then maybe that won’t help?
How can I tell when the extensions have loaded?
Is there a 3D mouse you can recommend that does not have these issues?


#4

I’m on my phone now so can’t check but I sort of recall it can happen even with the mouse unplugged. The definitive way to prove it is to disable the 3dconnection extension by changing its extension to something other than .rb. I believe it is in the /Library/Application Support/SketchUp 2018/SketchUp/Plugins folder (not your personal folder where most extensions are placed).

I have quite a few extensions installed, so I get maybe 3 seconds of beach ball as SketchUp loads them. When all toolbars appear and the app becomes responsive, the extensions are finished loading.

Edit: I have not tried other 3D mice so I can’t recommend anything.


#5

Hi slbaumgartner,

An update, I have just tried what you suggested and it worked. This was the first time I was able to actually do anything with the 3D mouse, and immediately discovered that it is doing crazy stuff, it is moving the cursor instead of the camera/orbit. I checked the driver for the mouse and it says it needs to be updated, but I am using the latest update. So it would appear that for the moment, I have to use the system without the 3D mouse, but that at least allows me to get some work done!

Thank you so much for your help.


#6

And another update.
I reloaded the 3D Connexion drivers, and the issue remained.
I checked the Activity monitor when SU was open, and it showed SU was using 18GB of memory, and climbing!

I then went into the plugins folder and changed the extension as suggested above, and now SU is running happily using only 162MB of memory, so that would appear to confirm your theory.

Now all I have to do is get 3D Connexion to step up and build a driver/plugin whatsit thingi that actually works, and everything will be great again.

Thanks again for your help. If anyone else has a suggestion for a 3D mouse that works with SU Pro 2018 on Mac, I’d love to hear about it.


#7

Another voice is always good, though this problem has been known for years and they haven’t fixed it yet :rage:


#8

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.