Hard crash after about 5 minutes of use


#1

Hi All. Hope you can help. Relatively new to SU and also community forums.

I’m having a very frustrating time working in sketch up, I’m work on a MacBook pro running OS High Sierra 10.13.5 (AMD Radeon R9 M370X 2048 MB
Intel Iris Pro 1536 MB)

Basically my SU is crashing hard about 5 minutes into some basic modelling on any file. Even files that are brand new builds with no imported data.

I installed SU as per the instructions on the SU website, deleting all the files and prefs.

A fresh installation is causing the exact same problem.

I’ve been searching on line and cant find anything relevant to my case… I see other users reporting a ‘bugsplat’ notice, I don’t get that or (even know what one is)

the only thing I can find is a thread that reads this…

SketchUp crashes on the Mac after prolonged use
This is a known issue that we’re currently investigating. For now, we recommend closing the Components browser and leaving is closed as much as possible.

“this is a known problem” Isn’t much help to me!!!

I dont have the components browser open! I have no extensions installed other than the ones that install automatically with SU.

Everything on the Mac freezes after about 5 minutes of basic work. I have to hold down the power button to restart and then do another 5 minutes before it happens again!

I see no spike in my activity monitor which I’ve left running to observe…

I’m not sure what data I can provide you kind people with to help me, please let me know and I’ll post what I can

Hope you can help!


#2

Hi

This is a little bit of a guess, but I’m wondering if it has something to do with the fact that you have a MacBook Pro with two GPUs.

I may be wrong on this, (I’m sure someone will correct me if so), but I’ve a funny feeling you have to tell Sketchup which one to use.

I’m using Pro 2018 on a Macbook Pro with only one GPU, and so far, no issues, (probably cursed it now by saying that).

Anyway, just a thought.

Kind regards

Mike


#3

In general, Apple’s graphics drivers are pretty stable and reliable because they control the variations in graphics hardware. But I faintly remember reading that a few specific models of MBP may have a graphics driver issue that causes SketchUp to crash. I can’t find the back posts right now, but I’ll look some more later.

The 5 minute interval sounds suspiciously like the autosave interval. Try turning autosave off in SketchUp Preferences and see if that helps. If the crashes cease, that will help Trimble track down the cause.