Memory consumption constantly increasing, then system freezes


#1

I use SU 2016 Pro and have been having increasingly frequent ‘out of application memory’ freezes on iMac retina 5K. It’s not just SU that freezes - most open applications stop responding to anything other than ‘force quit’.

I have just opened a new SU document, and as I watch, the memory usage in Activity Monitor climbs by the GB over a few minutes - starting at 3.6GB, and now (doing nothing) 20GB and still rising. Less than a minute later, it had reached 33GB, and is now still rising at 53GB.

Is this normal? If so, why?

I have 24GB total RAM.

I have a range of extensions and plugins loaded.

How do I track down what might be causing this? SU plugin/extension seems the most likely culprit - when I run out of application memory, it’s always when I have SU open and have been working in it for tens of minutes or more.

Would it help to list the plugins and extensions? If so, I can do that later today or tomorrow, but don’t have time just now.


Ram issues on MacBook Pro New User
#2

disable half of the plugins and and so on for narrowing to the causing plugin.


#3

Will do, but not for some time - have to go out now.

System displayed ‘Your system has run out of application memory’ after less than 20 minutes of idling, with SU open. Force quit SU, and the rest of it seems to be working normally.


#4

Have just a few minutes before going out.

Have disabled ALL extensions (though there are still a few plugins active), then restarted SU.

SU Memory usage started at 76MB, after few minutes risen to 89MB. Seems to have stabilised at that, at least for now. Will leave open while i’m out, and see what has happened when I get back in a couple of hours or so.


#5

I’ve had it happen with 3D Connexion SpaceMouse installed…

others have reported it with more than one renderer plugin and/or Vray installed…

many that ‘watch’ the model for material, component, layer changes can get confused when opening an empty model…

john


#6

Ah… There may be a clue. I had been trying a CADmouse, but didn’t get on with it and am returning it. Uninstalled the driver software, but forgot about the SU extension it installs.

Will see later if that was the culprit. It had been giving a Ruby console error on loading.


#7

That was it - enabled the extension, and memory usage started to climb rapidly by the GB.

Thanks, @john_drivenupthewall, for giving me the clue so quickly.

Will check if that has solved the problem completely, but even with extension unticked, though SU not restarted, the memory usage is already up to 11 GB since I started writing this, having stabilised at 90MB before i re-enabled it.

SERIOUSLY bad marks for the software from 3Dconnexion. Maybe it’s worse when the extension is enabled, but the driver has been uninstalled, but now I think of it, my memory problems probably started about the time I first installed the CADmouse and its software.

I know there are quite a number of heavy SketchUp users who use 3Dconnexion products, especially the Space Navigator and Space Mouse hardware, but I haven’t seen other reports of this unsustainable and rapid rise in memory use with their software.


#8

Well, My setup is quite similar except it is Windows. I have 3D mouse which I connect maybe once a month, but the extension runs all the time with my HEAVY sketchup model. And SketchUp doesn’t take that much of memory. Maybe it could be something that only happens in MAC?

I also have Vray installed, but only running the extension when I need it. Because of the reason that @john_drivenupthewall John has stated. [quote=“john_drivenupthewall, post:5, topic:25269”]
others have reported it with more than one renderer plugin and/or Vray installed…
[/quote]
No memory problem so far.


#9

Their Mac OSX support has been really spotty, and the Mac version of 3DxWare constantly lags the Windows version in both functionality and stability.

I’ve had the same memory leak issues on my Mac (2014 13" Retina MacBook Pro). Seems to be worse when I have Twilight loaded.


#10

I’ve now returned the CADmouse. It’s unusable in SU.

Have uninstalled the 3Dconnexion driver and control software, and disabled the SU Extension, but can’t seem to find it to remove it permanently - it’s not in default Plugins folder.

Maybe a system restart will remove it fully?


#11

For some reason, 3Dx doesn’t allow you to install in the default (user) plugins folder. You’ll likely find it in the following path: (see screenshot)

Macintosh HD/Library/Application Support/SketchUp 20xx/SketchUp/Plugins


#12

That was it. Thank you. I didn’t know SU ever installed to the /Library/… folders rather than ~/Library/…


#13

SU doesn’t, but 3Dx does… and without giving the option of installing to ~/Library …another annoyance of their crippled Mac support.

The worst memory leak I had was when I somehow had different versions of 3DxWare installed in both Libraries.

I love my Space Navigator in spite of the driver issues, and I almost bought a CADmouse. Only reason I didn’t at the time is that they weren’t supporting it on the Mac initially. Given your experience, I’m glad I passed.

I ended up buying a corded Logitech m500 for Layout work at 1/3 of the price of the CADmouse, and I’m very happy with it. (I use a Wacom tablet with the 3D mouse in SU —which I love— but it’s too fiddly and not precise enough in LO)


#14

Well, I’ve given up on the CADmouse, and sent it back to Amazon with a 1-star review for use with SU and Mac OS X. Essentially, it’s unusable as shipped, and even with the fix I found on this forum for getting the wheel button to orbit it isn’t usable with this colossal memory consumption and system freezing.


#15

I’m revisiting this old topic based on some observations I just made with a new Space Navigator mouse. It seems that on Mac there is a conflict between the plugin and the blank model that SketchUp creates automatically when you launch it. If I start a fresh copy of SketchUp and then just watch the Activity Monitor, SketchUp’s memory usage climbs steadily until it causes system issues because there is none left. But if I immediately close the initial blank model, the memory stays stable - even if I then manually open a blank model using File->New or open an existing model. I think there is a race condition that breaks their plugin if a model is open before the plugin is initialized. I plan to report this to 3dConnection and see what they say.

In case it matters, I’m using SketchUp 17.2.2554 on a mid-2012 MacBook Pro Retina and macOS 10.12.5.


#16

Great catch Steve. I’ve had this issue intermittently, and wondered why it isn’t always a problem.

Maybe it’s that I usually open the SU file directly (which doesn’t launch a blank model), as opposed to opening the app first (which does), then opening the desired file.

Another issue I’ve been having is that my Space Navigator fails if I have instances of SU 2015 and SU 2017 running concurrently, even though I have the 3DX plugin installed in each.

I had noticed previously, that I had consistent memory leaks in SU which I traced to having two copies of the 3DX plugin: one in the User/Library/Application Support/SketchUp 20__ and one in the Device/Library/Application Support/SketchUp 20__.

Interestingly the 3DX installer now only allows installation at the device level, perhaps to avoid this state.

I’ll be curious to hear the response from 3DConnection. I love their hardware but their MacOS support over the years has been spotty at best.


#17

What version of the 3dconnexion driver are you using? I know I had to go to their site to download the most recent version, but everything works great, now.


#18

Just today downloaded their latest. What I reported happens with it.


#19

It’s true that their recent MacOS drivers are much more stable than a year or two ago — but I still occasionally get the race condition that Steve describes. (I have the current plugin version)

Now that my SSD is more full, my first indication of the problem is an OS alert telling me that my drive is almost full. Turns out that it’s because SU takes on more and more virtual memory due to the 3DX memory leak.


#20

Gonna have to look into this!