Pushing out rectangles on a grouped plane

Left Hexagon with Windows.skp (197.3 KB)

I made a hexagon with 2 offset boundaries. I grouped it. Then I pushed one boundary out for 40’ and grouped that. I drew 5 windows on it and made the first one into a component.

I am unable to push the windows out.

Suggestions please.


Your rectangles are components separate from the building. While you are editing the window component you cannot make changes to the building geometry. You need to be editing the building, not the window.

Yoiu should go through the tutorials at learn.sketchup.com. This is a fundmental thing in SketchUp and you have to get it sorted out before you can make any good progress.

1 Like

When I asked a question a few weeks ago, I was asked to go to the Learn section. So I did. But I did not learn anything about how to edit a building when I want to push out the window.

Please amplify.


Hey DaveR or Anybody,

At your suggestion, I have gone over the various Learning lessons. However, I don’t remember learning how to extrude a rectangle component out of a grouped rectangle.

Please be so kind as to make an animated gif along with a bit of text explaining the process. I’ve worked for hours looking at the forum, etc. trying to solve this problem today.


This sounds a little more complicated than it needs to be.

Here is a collection of 3 rectangles. One is just geometry. The second is a group. The third is a component. For one, geometry, you just need to draw your shape (window). For groups and components you need to ‘click into’ the context. Here I did that and erased the rectangle.

Here is a ‘wall’ of geometry; a group, and a component. I clicked into the context of the component and the group. For the geometry I, no need to click inside. I used Push/Pull. Make sure to push to the face to the other side (you can see when that happens if you look at the cursor).

Can't make holes in Grouped Rectangle

I have SketchUP 2023 and I here’s what you see in the animated gif I just made.

I made a rectangle and added some depth to it. Then I made it into a group. Then I drew a rectangle on it. I was unable to extrude the rectangle.

Any idea what is wrong?


You need to open the group for editing.

You drew a rectangle ON the group not inside of the group, on the geometry.

First, on geometry. Second ‘ON’ group. Third, inside of group, on geometry.

Got it, thanks!

Rectangle within Rectangle Unsuccessful
I spoke too soon. I tried to follow your instruction. Looking at the animated GIF, it is obvious that I did something wrong.

What was it?


several things.

  • you are in the right (= editing) context when you use the ‘Push/Pull’ tool. But you can’t inference on an edge or vertex on the back side of your slab from this camera position. Orbit a bit to see at least an edge.
    Or hit [k] to see all the back edges of that slab to use for inferencing.
  • You can only cut one face with a ‘Glue to’ > ‘Cut opening’ component. So even after deleting the inner rectangle after push/pulling to the back you’ll still see the entire large back face. A 'Intersect Faces > with model from within the highest context (the face context) will help to create the small back rectangle and to delete its face.

I think stopping what you are doing and learning how to use the various tools would be good for you in the long run…

1 Like

Don’t create the component. Just draw the window on the geometry of the wall and push/pull it.

Some little errors have crept into the model you shared. Go to Window → Model Info and remove the checkmark next to, “Enable length snapping”. That will help prevent accidentally making measurement errors. You should save a template with that turned off.

*Use inferencing arrows.

Why did you created a component inside the group? Just draw the rectangle, don’t make it a group or component and then use the push pull tool to make a hole. If you want yo create a window component do it outside the group.

I’m sure that all this stuff is explained on the different courses from the sketchup website.

Hello Bmike,

Thank you so much for that tip. Right now I’ve finished the first playground and am on the section that talks about edges & surfaces. It just told me to open up the example file.

However, when I tried to open the example file, I got the error message you see in the attached file. What should I do to open the example file?


@colin @TheOnlyAaron - guys - can someone from the SKP team jump in and help Peter with this? I haven’t looked at / done a tutorial in (checks notes) 10+ years.

Is it a .SKP file? I would think if you saved it to downloads then SKP would recognize it and open it.

This looks like a job for @TysonK !!

1 Like

Yes, it’s a SKP file.


Hey Bmike,

You were right. I dragged & dropped it into my Downloads file. Then I was able to open it.
Thank you.