Proper file association and SketchUp 2020

I’ve installed sketchup pro 2020 multiple times with the same result: It shows up in the start menu as “2020” but files inevitable still launch in 2019. Any attempt to associate .skp files with 2020 fail because 2020 is not listed as an option. Anyone else experiencing this?

Did you install SketchUp 2020 correctly? Did you right click on the downloaded installer and choose Run as administrator? Or did you just double click on the installer to run it?

I ran it as an administrator. Twice.

This is after installing it, again. Sketchup 2020 does not show up when I use “Choose another app” either. Like I said, it DOES show up in the start menu and it does run. I would simply like it to be the default handler for skp files. Before I fully configure it, it would be nice to know if this issue will be dealt with in an upcoming incremental release.

Is the version of 2020 you are installing the latest one?

It will be fixed in an update, but I don’t know when that will be. I haven’t seen three entries of 2019 before, but at least one of those is really 2020.

I used the one that my licensing update email pointed me to. 2020.0. Is there another?

Yes, 2020.0.1, … refer to Release Notes.

On the main context menu, the emboldened Open (at the very top) should open in SU2020.

There already was an upgrade that fixed some bugs. My “About SketchUp” window shows 20.0.373

Did it create shortcuts on the desktop? They could be called 2019, too

Version 20.0.373 didn’t fix the association bug. Since upgrading to it I also noticed that the Sketchup Pro 2020 shortcut icon (desktop, or wherever you keep it) is blank when using small icons/list view.

That’s odd, I see the icon ok.

There must be something about different versions of Windows. I have had this since I first installed SU2020. It’s the same on my other computer, too. Both running 20.0.373.
Screenshot - 2_21_2020 , 9_15_07 AM

Here is my view on the situation:
2020-02-21_9-52-50
Ver. 20.0.373

This is the situation on my machine. I have 2018, 2019 & 2020 installed.

Clipboard01

1 Like

I have yet another version…
image

The double 2019 in the open with menu is a known issue, I was caught out on that and Colin put me in my place.

I have the same muddy mess here.

Open With Madness


I don’t see SU failing to manage fundamental registry entries as an OS version issue.
OS Build