SU trying to open 2020 files with SU 2019

I have SU Pro 2020 License No ——————— and have just installed the latest update, however when I try to open SU or Layout 2020 files by clicking on the file it tries to open in SU 2019 and tells me the file was created in a later version of SU, (which I already have installed and am using all the time).

I have had this problem ever since I downloaded SU 2020, but have put up with it hoping that an update will solve the problem, however installing SU 2020.1 has not made any difference.

I have tried uninstalling and re- installing including - run as administrator,but still no change. Can someone please help me to resolve this issue?

In the Open with menu you may notice two copies of the same version. That might be SketchUp 2019, but it could be 2018 or earlier. For me at the moment I have two copies of 2014. That’s something wrong with the installer, it doesn’t associate SKP with 2020, and can leave the open with menu looking strange.

To fix that, right-click on any SKP, select Open with and then Choose another app. In the window that appears check the box to say always use this to open skp files. Scroll down the list to choose More Apps, and again to get to Choose another app from this PC.

Find your way to here: C:\Program Files\SketchUp\SketchUp 2020\ and select SketchUp.exe.

SKP should then open with 2020 when you double click on them.

Installed as administrator.

Doesn’t work for me…

My workflow gets round it but the occasional time I forget and double click on a file it’s mighty annoying!

Thank you, Colin, I have tried that 3-4 times but unfortunately it has not worked, any other suggestions? Sketchup 2019 appears 3 times in Open with!

When you installed SketchUp 2020, did you right click on the installer and choose Run as administrator?

I had this problem with win 10 and finally had to go in and uninstall SU2019 to be able to associate the file with SU2020. It kept changing the association back on me also.

Yes, I did click run as installer, will try uninstalling SU 2019 and see if this helps.

It’s a weird thing that Windows installs seem to be so different. Zarloff had to uninstall 2019 to get Windows to default to 2020. For me it worked as expected and for some people who tried 2020 and then uninstalled it, they can’t get Windows to go back to using 2019 as the default.

It’s a black hole.


I have 2 entries of 2019 on the “open with” list, the TOP entry of mine opens 2020. I Think that once you have successfully opened a SKP with 2020 then Windows should default to that when double clicking.

Mine works fine at the moment but I don’t usually double click SKP’s to open them. I launch SketchUp first and then open files from within SketchUp.

I find it very odd that the EXE forcing method suggested by Colin above doesn’t work.

I have uninstalled SU 2019 and gone thru Colins’ process again and can now open SU 2020 files by clicking on them, but the thumbnail next to all my Layout files has greyed out and the files will not open at all.

Strange, a black hole alright. Any other thoughts anyone?

You could repeat the steps, only set .layout files to open with LayOut.exe in this folder:

C:\Program Files\SketchUp\SketchUp 2020\LayOut

If you open the file from the windows file explorer it will open the file in a second copy of SU so you can view both at the same time or compare them or work on both at the same time.

Sorry used the wrong word should have said run as administrator not installer.

1 Like

Thank you, have done that, but the LO file will not open until I click on “open with LO 2019” and then it opens with LO2020, but the LO thumbnails are still greyed out.

Strange behaviour indeed, hopefully will get a bug fix soon.

Is there a fix to this problem? Thanks

Which problem exactly? Opening newer Sketchup files with an older version?

I have 2020 installed as well as 2017-2019. When I double click in Win10 file manager a 2020 file, it won’t open, it tells me to get 2020. I have done the uninstall and reinstall of 2020. I can only open 2020 files directly in the SU app. It also opens when I click a “bogus” 2019 version that apparently masquerades as 2020 in “Open with…”. When I search for other files to open “on this computer” ie SU 2020 it doesn’t work either. In short the same problem as everyone else in this thread.

Yep, same here - it’s annoying.

I manage to avoid the issue but occasionally I forget

After some of my earlier suggestions I found that a more sure way to fix the problem was to go into Default Apps, choose Choose default apps by file type, then scroll how to .skp or .layout in the list. In the apps that you will see that can open that file type, choose the upper one. It may be a duplicate of SketchUp 2019 or earlier, but really it is SketchUp 2020.

Test to see if you picked the right one in the list by double clicking on a SketchUp file.


That works for me - thanks Colin

1 Like