SketchUp not letting me access files

I subscribed to the Pro version of SU on June 21st. I’ve been able to use my account just fine up until I cleared my history cache this morning. Now I’m getting a message that says my files were created using an older version and it won’t let me access or open any of my files. Any advice on how to alleviate this issue?

You are using SU pro? That Is not web based and should be unaffected by Clearing your browser cache. The message you see says this was created by an “older” version? Not a “newer” version of SU? All SketchUp versions can open every previous versions files, so an “older” version file should Open fine. Can you show a screen shot of the message you are seeing? Are you currently signed in to SketchUp?

That’s the message I keep getting. I redownloaded the SketchUp 2020 and it’s still doing the exact same thing. It won’t let me open any of my files at all, including ones I just worked on yesterday!

ok, so I just logged in using the “start your 30 day free subscription” and it let me in, but I shouldn’t have to do a trial as I’ve already paid and my account reflects that when I go in. I don’t want to be charged again at the end of 30 days. Not sure what’s going on. I checked and my email and all of my details are correct

See if you can open your files from the file menu in SU 2020.

It sounds to me possible or even probable that the OS has retained an old file association between the .skp file extension, and SU 2019. Did you previously use the desktop version of SU 2019?

Use Finder to reset the File association.

R-click on an skp file, Open with, then Other.

Choose SketchUp 2020/ in the Applications browser window that opens.

See that Enable: is set to Recommended Apps

Check the box Always Open With, then click Open.

That SU file should now open in SU 2020.

Close SU.

Go back to Finder, R- click again on the same file, and choose Get Info.

In the window that opens, select Change All so that all SU files open with SU 2020, and confirm with Continue when asked if you really want to do this.

I found when I just did this, that before the change would ‘take’ I had to click on the lock at bottom right of the Get Info window and provide my password, to unlock the setting.

That worked! I trashed the 2019 version so hopefully I won’t have any more issues. Thanks so much for your help!

Glad it’s fixed things for you. While checking out the steps on your behalf, I found that my own default file association was weird - a program I didn’t recognise, but it had SketchUp and sql in its name! and wrong.

So thanks for your question.

Glad my answer fixed it for you.

PS. You didn’t need to trash SU 2019 - you can happily run two versions of SU at once - unless you just upgraded from 2019 to 2020, in which case I think the licence for 2019 is discontinued after you register the new version.

yeah, I had the free version of 2019 and the Pro 2020, so the 2019 really isn’t necessary any more. :slight_smile:

You mean the 2019 Pro trial? There was no free version of 2019.

oh right, it was the trial…

With subscription, you can activate all versions that have the ‘sign in to activate’ feature, on any machine. Each version counts as an activation, though.