Trouble opening SU 2019 files & not auto-saving

When I click on a SU 2019 file to open it, I get the message “the file was created in a newer version of SketchUp. You have version 18.0.16975. You need version 19.0.685.” , it will open fine if I click on open with SU 2019. Also I have SU 2019 set to Auto-save every 5 minutes but it is not saving or updating the skb file until I save manually. Maybe these 2 issues are related, so I would be glad of any help available.

When you installed SketchUp 2019 did you right click on the downloaded installer file and select Run as administrator from the context menu? If not, SketchUp is not installed correctly and you need to repair the installation.

The .skp extension is still set to open with 2018. As @DaveR wrote, that is one of the possible consequences of not installing SketchUp the right way.

Thank you for your quick response, I am sure that I did that. When I try to repair SU 2019 it only gives the option to uninstall. If I do this and re-install will it upset all my settings, plugins etc or can I do this and retain SU 2019 as I have it set up now?

When you right click on the installer file you downloaded and you select Run as administrator, you should get an option to Repair. Make sure you’ve quit any running instances of SketchUp, first.

If you choose Uninstall, and the reinstall, the extensions you’ve installed should still be present. They aren’t in a folder affected by uninstalling.

Thank you, problem solved, have re-installed & repaired as suggested, why I didn’t do this before i don’t know, old age perhaps?

1 Like