Problems copy & paste Information between SketchUp models

I am having problems coping & pasting information (like site plan) from one sketchUp model to the other. I have sketch 2019. I tried many different ways to copy paste different layers, but nothing.
-Command+C & Command V
-I restarted my Mac twice.

I can’t think of anything else. Please help.

⌘A >> ⌘C >> ⌘N >> ⇧⌘V

select all > copy > new > paste in place

skip ⌘N if you actually click on a second SU document…


1 Like

John thank you for your time. It’s not working.

Can you share the .skp files you are copying from and too?

Hi Dave,
Nice to talk to you again. Below are my files. I am trying to copy the pitched roof layer from new pollock into the Pollock2.0

new pollock .skp (185.1 KB) Pollock 2.0 copy.skp (561.2 KB)

Hi Melina. It’s been awhile.

Have you tried copying from the one file and then Paste in place in the other file?

BTW, I sent you a pm.

If copy and paste is troublesome for you, you could make the roof a component (if it isn’t already) and then context click it and “save as” a discreet Sketch-up file which you can then import into your other model.

1 Like

Happy to know you’ve got it sorted out.

Thank you everyone for the help. It got resolved.

1 Like

Hi @Melina

Can I ask how did you get it solved, as I’m facing the same issue.

Thank you


Edit- Paste in Place

1 Like

Thank you


I am experiencing the same problem when I try and copy/paste from one window to another. I am running Sketchup pro 2020 and OSX10.15.3. Basically I thought that it was all items but it appears to only happen when something is grouped or a component. If it is one of these then I can copy and use the menu item to “Paste in Place” but paste itself does not work. Although it does works on loose geometry. Within the same window Copy and Paste work normally. Any further help, advice etc…would be greatly appreciated and I can upload a simple file if that helps. I don’t think it happened in the past with earlier versions

many thanks in advance


P.s, same question is posted on Sketchucation

Same issue here. This is a bug that started in SU 2020, did not happen in SU 2019. In SU 2020 on Mac, can no longer copy and paste from one document to another using the normal paste command, where you should then be able to click for where to place the pasted geometry. Only paste in place works in this current version. This is a serious hindering to using Sketchup.

Can you describe or show an example? Copy and paste works ok for me. I can copy, new, paste, move around until I like where it is, and click to place it there.

upload your template…


This is a little bit glitchy. I hadn’t noticed as I normally use paste-in-place. If it’s somehow related to template, here’s mine:
Gordon Yellow Backface 11-4-20.skp (11.4 KB)
Copying loose geometry works, but sometimes it’s not visible, zoom extents displays it and I think no more about it. I tried a group and it beeps at me as if there’s nothing in the clipboard. The Finder confirms there’s something in it, but obviously it can’t display it. I changed default template to one of the standard ones that came with 2020 and it worked fine. I went back to my old template and it worked a few times then failed again. Now sometimes it works and sometimes it doesn’t.

Even when it is working, if the mouse is totally still the pasted object doesn’t get drawn until the mouse is moved, but that might be normal. It is the four-arrow mouse cursor, the same as the move tool.

I use a clipboard stack program for multiple clipboard items (CmdVees) which can cause problems, but I’m seeing the same thing as other people here.

Could this be something to do with view hidden being split into hidden geometry and hidden objects?

I use FlyCut for clipboard control, though it seem mainly for text. It’s highly likely CmdVees is to blame. You could turn that off and then repeat a test that had failed.

I can paste into your template, of copy and paste into something else ok. Other than your change of back color, it seems normal.

I can’t get it to fail at all now whether CmdVees is active or not. It doesn’t redraw until the mouse moves but that’s pretty trivial.

The pasted objects not appearing until you move the mouse is normal. You could if you wanted immediately click, and that would make them appear and also place them. I don’t know if that was done intentionally, but it does give you the option of carefully pointing to where you want them before doing the paste, and then do a click.