Copy and Paste between different models not working in latest release

I am using Copy and Paste to move parts of my SketchUp model to a new file for some detailed modeling, to copy a detail, etc, but this doesn’t seem to be working on the newest version of SketchUp. It appears that I can copy something, but the options to Paste or paste-in-place in the new file are greyed out. I also can’t use the Control C and Control V options.

This is such a valuable feature…I hope it still exists!


Multiple posts on this topic already. There’s a work around until it is fixed.

Please complete your forum profile with your current SketchUp version.

1 Like

It is a known glitch, and the developers have promised to fix it. Meanwhile, as a workaround, go first into the destination model and copy something to the clipboard. Then you can go back to the source model and copy your items, and paste to the destination should now work.

1 Like

Thanks all!

This is such BS!! If the developer know it’s a fricking problem then get on it and fix it!!!

They already fixed it! The fix was released yesterday.

20 hours ago:

Your profile is out of date. Please correct it.

1 Like

Thanks for the update Dave. BTW, nice drawings on Flickr! I too have been using Sketchup since the beginning, wasn’t the parent company @lastsoftware or something like that?

I have the same problem with Copy/Paste and Copy/Paste in Place. I try to follow your suggestion but it still nor responding. It’s a real big problem.
I’m working with iMac 5k 27" 2019, Radeon Pro 580X 8GB, 64 GB 2667 MHz DDR4, Sonorama 14.1

BTW I’m using SketchUp 23.0.418

It was fixed already almost three weeks ago. Update to the current version.

1 Like

Here´s the link to download the latest releas for MacOS.

1 Like

The copy and paste issue was only on Windows. There were keyboard shortcut issues that were also only on Windows, but maybe some affected Mac?

Do your copy and paste in place steps fail when using the menus, or only when using keyboard shortcuts?


I’m a little confused reading up through this string: so the issue hasn’t been resolved on the latest PC update or it has?

I HAS been fixed in the latest release for Windows. It was fixed three weeks ago.

cldjr is using a Mac, and reporting a Windows-only issue. It was fixed on Windows.

… and also on MacOS 14.1 which is not yet fully supported.


Yesterday, without touching/modify anything on iMac Sonoma 14.1, Copy/Past and Copy/Paste in place was working !.. ???

1 Like

It’s not recommendable to update to the latest OS without checking if it’s supported by the softwares you use, sketchup 2023 doesn’t and will never have support for Sonoma, maybe the developers can make some fixes to make it run a bit better but only sketchup 2024 will have full support for sonoma.

1 Like

Thank you! This really helps. :pray:

Nov 20, 2023 from San Francisco, CA

SketchUp Pro: Version 23.1.341 / MacOS. Ventura - Version 13.6.1
I have the option to update to macOS Sonoma 14.1.1,
but I am holding on an update until I can get more info.

My “copy and paste” function has stopped working. I tried your suggestions. Can you offer any suggestions for the Mac Platform? I know it’s stated a Windows problem, looks like it’s a Mac issue as well. I am trying to copy and paste a simple component from one doc to the other. It copies/pastes within the doc itself; the issue is only when copying from one doc to another. I have save and re-saved both, and the problem is not solved. Would appreciate a quick response. Thank you.