Problem with Architect Tools Menu Display


I have installed the Architect Tools and the tools themselves display fine but the menus do not. Can anyone suggest a solution please?

Many thanks


Go to View > Toolbars and the Toolbars dialogue box appears. All of the installed plugins that have associated toolbars will show in this dialogue venue with a checkbox next to each. Locate the “Architect Tools” name and be sure to tick the appropriate box to get the toolbar to appear. See the attached image.

If your question has to do with tooltips not displaying on the toolbar when you hover over each tool, you just need to position your cursor over the tool (hover) and read the corresponding description in the lower left portion of your screen.

1 Like

Does this mean you see the toolbar for the extension, but not the menus?

Hi Thomas

Yes that is right. The tools are there but menus/windows missing.

Thanks for your help


Did ticking the checkbox in the Toolbars menu solve your problem? It would be good to indicate whether it did or not.

Hm… I had another user contact me yesterday, about Material Replacer. The extension appear to be installed and show no indication of errors during startup. But there was no menus. And that extension didn’t have toolbar so there was no way to use it.

I’m not sure what is causing this, but can you provide more info about your system? What OS? What SketchUp version?

Hi Thomas

I’ve just upgraded to SUP Pro 16 and running on OSX v10.10.2. As I say the tools are fine - I tried using the multiple push pull for example but without the menus I can’t get the full benefit. Thanks very much for you help.




Yes that is ticked and the tool bar there but the menus missing.

Thanks for the suggestion though.



Can you open the Ruby Console and tell me the result of $tt_menu?

Hi Thomas

No response to the command.


Hm… this is a mystery…

Can you install this RBZ please? Then go to Plugins > Collect Data and return the SketchUp-Diagnostic.txt file created on your desktop?

su_diagnostics.rbz (3.3 KB)

Can any of these have to do with Extensions Policy?

Thomthom’s extensions are probably signed by trimble, but perhaps something there just causing it to now load up properly?

Actually - no. I think only Vertex Tools, SUbD and TT_Lib is signed. I’ve not updated the others. It actually takes quite a bit of time to re-upload all my extensions (50 of them) and I was hoping for a bulk feature.

Didn’t consider Extension Policy though… Would be interesting to know what this is set to.

Then this might answer at least part of my query.

I use your V-ray tools, and I started having Vray launch upon starting SketchUp even when it was disabled. (This issue started since SketchUp 2016 Update). I need it disabled until I launch Vray from your extension (This was the purpose of that extension, I am sure you understand what I mean) There is launch order for signed and un-signed extensions according to help page. Which I think is the cause of the issue.

@Jasone - which version of SketchUp are you using? I just had another user for another extension report that updating from the original 16.0 release to the 16.1 release fixed his issues. Could the same apply here?


I have properly installed the “architect tools” plugin for the trial version (2021), but it doesn’t show up anywhere in the sketchup

I would be glad if you help, thanks

Did you also properly install the required TT_Lib2 files?

Yes the same but it still doesn’t show

What is the same?
After installing both Architect Tools and TT_Lib², restart SketchUp and you should have a menu items (under Extension menu) as well as toolbar will be available to select.

1 Like

Still doesn’t show :frowning: Is it because it’s a trial version?