Problem Exporting DAE OBJ FBX to Blender w/o triangles for quad modeling for High Low Texture Bake for Mixer 2020

So, I’m trying to take a model that I created in SketchUp a while back and ultimately do some cool 3D painting on it in Mixer 2020. It would be similar to how it’s done in this video:

Here’s the SketchUp Model in SU:

and here’s the Wireframe

I have the whole model grouped by material, for example here’s the red painted brick material group:

here’s the dae export settings

Here’s the model imported into blender:

here’s the wireframe in Blender:

I tried using the plugin and followed the steps mentioned here: https://www.dndrawings.com/sketchup-to-blender-dae-clean-tutor

and it did produced this:

I tried exporting without triangles and it produced this:

Here’s the wireframe from producing without triangles:

I need it to ultimately make it look like this:
fh_frontwire

Here’s a link to the SKetchUp fileand DAW, OBJ, and FBX (all with and without export triangles):

so that I can make a high poly and low poly bake to use in Mixer. What is the best way for me to go about doing this?

Any suggestions? Am I asking in a way that’s confusing? Is there no easy way to do what I’m trying to do? I basically need a way to export the model without the diagonal lines being created

The Triangulate all faces is what introduces the diagonal lines. You could try not doing that, and see if Blender can cope with faces that are not surrounded by only three edges.

I have. This is what comes up:

@colin it like deletes some geometry (the back corner wall) and adds some new faces (all the windows have new faces on top of them). Here’s the wireframe:

I did a test, the picture shows the same cube with and without triangulation, so I thin that will solve the problem.

I wondered if the new problem was because some faces are reversed, but I tested that and Blender seemed to cope. You could still set the face style in SketchUp to Monochrome, and fix any faces that are reversed.

Could you make a small model that shows the problem, and attach it to your post?

1 Like

I will try that now. For what it’s worth, I’ve double and triple checked and I can’t find any faces that are reversed anywhere. I have back faces colored bright pink in this image

It must be something else then.

I found your earlier link and will look at the file. Meanwhile, I tested with FBX, not triangulated, and using the AutoDesk FBX converter to make it be binary. It then had weird shading, but otherwise looked like it worked. I’ll try that on your house.

1 Like

@colin I tried doing it with just the “red painted brick” layer and it went from this:


to this:

I did a lot more tests. The issue isn’t anything to do with Blender. It seems that the export to Collada of a face with disconnected holes will fail to export some or all faces. Connecting one corner of the hole to an outside edge doesn’t fix it. Connecting two corners to an outside edge does fix it.

That seems unexpected behavior, I will check if there is a known problem, and if not I can log a bug.

In the meantime, triangulate all faces works around the problem by effectively connecting all hole corners to outside edges.

For your painting needs, does it matter if diagonal lines would show up in wireframe?

1 Like

@colin Yes, it won’t be possible to use Mixer effectively if the diagonal lines are there. I will have a more detailed explanation for why this is shortly, but wanted to respond ASAP. It’s actually be a smaller problem for me in a number of other applications in the past, but this is one of the first times it’s really preventing me from doing something entirely.

I have also come across a few other posts online from folks dealing w the same problem, none of whom seem to have found a resolution

You could add a few edges

and in Blender you’ll have this (without triangulation)

1 Like

@colin @mihai.s So I just added horizontal lines at every corner of every vertice in the painted brick layer and came up with this:

Seems like some of the wireframe problems are addressed, but there’s still this weird face getting added on top of the windows?

Also as I’m adding lines I’m finding that certain walls keep getting removed. When I try to add them back in, they seem to have a hard time acknowledging the existing penetrations? See below:

I wonder if this is related to the way the exporter is reading the geometry

Apply the same principle, add a few edges

Nice. Any chance you know of an extension that does something like this automatically? I have a ton of models that I’m now going to have to do this for

I’m basically running through and doing all of this manually right now. Super time consuming. Not sure if this is sustainable. Might end up taking me 6 hours on this model alone and I’ve got 10 more models like this at least.

@colin here’s an image that I think captures the root of the problem (or at least part of it)

On the left you can see two windows side by side in SkethUp. One of the windows has the lines drawn. The other window does not. On the right you can see how the DAE (w out triangles) comes out when imported into Blender. The window that has the lines drawn from the vertices comes out as intended. The one without for some reason creates an unwanted face.

We’ll see if it’s something that can be fixed, but it may be a limitation of Collada. I’ll do more tests.

@colin for sure. In the meantime, can you suggest anything that might help me avoid spending 6 hours drawing all these lines on manually?

I have an idea I’m trying out. But I’m stuck on something simple. In Blender I can ask for something to be done, say right-click Subdivide, and in the bottom left of the window options appear. I can’t figure out how to make it do the thing that I have selected. No subdividing happens. I tried Enter, left-click, staring at it.

In Blender, how do you make it do the menu item that you have chosen?

1 Like