Assistance with exporting

Hi All,

Apologies if this is a bad question, relatively new to SketchUp software

I need assistance trying to export a SketchUp model to Blender for rendering.

I cannot use DAE as my blender hangs infinitely and won’t open the mode.

I have tried to use .OBJ to convert however textures won’t appear correctly, looking to confirm what I’m doing wrong.

I’ve attached pictures showing the model in SketchUp with textures and what it looks like when imported to Blender.

I opened the model in 3D Viewer to check if it was a problem importing in Blender and it also shows no textures.

Thanks,
Cameron

!

If you have applied your materials to the back-faces, then they won’t be exported.
To check this first set your SketchUp Style to have a distinctive back-face color - e.g. bright blue.
Next view a part of your model that seems to have the problem.
With View > Textures switched on it should look OK.
Now change to View > Monochrome… if you now see lots of back-faces that’s the issue…

Materials must always be on the faces’ fronts.

Faces can be reversed using built-in context-menu tools, but there also plugins that might help to correct you ‘sloppy-modeling’…
Report back and someone will advise you further…

1 Like

Thanks for this, the plugins would be much appreciated.

Thanks

Perhaps if you showed us screenshots of the issue Textured & Monochrome we could advise more specifically…

One that springs to mind is available from SketchUcation [mine] - get a free membership, if you don’t already have one…
Please read its instructions carefully etc…
It works if you have textured the backs by mistake and there’s no front material etc… but there are several permutations…
https://sketchucation.com/pluginstore?pln=FixReversedFaceMaterials

Look through this topic, you may have a similar issue:

I think that taking the model via Meshlab helped, or selecting faces in SketchUp and setting that part of the texture to be unique.