Some textures not exporting

Hey there!

I was making a model for NoLimits 2 but when exporting to 3ds some of the textures are just not included.
I have no idea what’s causing it and it’s kinda starting to drive me mad :frowning:

Do you guys have any idea what may be causing this?
I tried adding them deleting and adding them back.
Weird thing is that they do work in a blank project o_O

Exporting to a google earth project shows the textures in the folder but for 3ds I cannot get it to work…

Can you upload the .skp model here , so we can have a look?

How do you detect this? Are they not appearing in game or do you open them again in SketchUp and textures not appearing?

1 Like

Guessing a bit here. If you only applied texture to some component or group as a whole, and not to its faces, the exporter (and many renderers) may just ignore the texture.

Might that explain it?

Or you may have had some back faces outward, and applied texture to the back face. Again, that might cause the texture to be ignored by the exporter and/or renderer. You can see this by selecting the Monochrome style, and look for blue (back) faces instead of white (front) faces

If I export to 3ds the textures that are exported appear in the folder.
Station.skp (1.2 MB)

As @john_mcclenahan suggested, a great many of the faces in your model are reversed:

1 Like

O gosh, I did not even know that was a thing!
Is there any way I can reverse that?

(What is that Style called by the way? I cannot seem to find it)
Edit 2: Found an option to reverse the faces by clicking on them but how exactly do you get that Style. Under what folder is it. I just cannot find it o_O

1 Like

That is the monochome setting, available within any style. It is most easily set via the styles toolbar or a shortcut, but you can also edit the current style.

You can either select reversed faces, right click and choose “Reverse Faces” or else right click one that is correct and choose “Orient Faces”. The former is 100% reliable but sometimes quite tedious. The latter can sometimes be fooled by places where geometry connects in ways that SketchUp can’t resolve for which should be in vs out.

Edit: many of us edit the style so that the back side of the default material uses some outrageous color that is easily seen and won’t appear anywhere else in the model (I use a neon green). That way in monochrome mode any reversed faces literally jump out at you.

In examining your model, I found this place where the gable end has no thickness so you can’t win - either the side seen from outside the building or the one seen from inside is always “back”.

37 AM

1 Like

Thank you so much!
Yeah after I messed around with the styles I found the ‘back’ color option. Set it to Ugly red and noticed that problem as well :slight_smile:

Would never have been able to fix this problem my self :stuck_out_tongue:

EDITED to make it clear.

The solution is not change back faces color.
The solution is orienting correctly the faces.

You misunderstood. The right solution is to correctly orient the faces. Editing the back side color just lets you find them more easily, as shading can sometimes make the default white front look gray.

1 Like

I was trying to say the same :smile:

1 Like

Works like a charm now :smiley:

2 Likes

Good work.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.