Building Rooftop textures are not exporting


#1

When I try to export a FBX with textures applied, the exported FBX shows the textures on the 4 sides of the building, but not the roof.

How do I get to export the textures on the roof too?


#2

Hello @dro305,.

Questions like this (“how do I…?”) are usually answered best when the model is posted along with the question. That gives us a chance to see what you see and may prompt a response more easily.

Welcome to the SU Community Forum, btw.


#3

this is how it looks in sketchup


#4

and this is whats exported


#5

thanks i posted some pics below.


#6

Is it a case of the faces being reversed in the model? Can you post a screen shot of it in SketchUp with the Face Style set to Monochrome?


#7

sure, here it is in monochrome


#8

It looks like all the faces are reversed. That blue is the default back face color. Reverse the faces so they are white side out and try again with the export.


#9

Thanks a lot. I will give it a shot. Do you know how to reverse the faces?


#10

Select the faces, right click and choose Reverse faces from the Context menu. If the building is all connected geometry (not separate groups or components), triple click on it with the Select tool and then right click on it to get the Context menu.

It is best to do good housekeeping as you go along and correct face orientation as soon as it happens. It’s generally a whole lot easier to fix them as you go than to have to go through an entire model to repair issues due to poor working habits.


#11

Face orientation is generally almost a non-issue if your model will stay within SketchUp, but it becomes important if you need to export it to other applications or if you use a renderer for photorealistic images.

Anssi


#12

If you have a lot of already textured faces, you can have a try with Fredos ReverseOrientFaces to speed up that process (but you should learn doing it by hand before to know whats going on).


#13

Ok so I inverted the faces and inverted the textures too. Now I’m trying to reposition the textures but I can’t even bring up the Context menu. i right click and nothing. control click and nothing happens either. im using a wacom stylus, i checked the buttons and they are set to right click. I’m even control click and nothing. is there a way to get to the context menu otherwise?


#14

The Position Texture tool is available only if what you have selected is a single face.

Anssi


#15

So it should be greyed out? Thing is, no context menu pops at all when I right click. Im sure I only have one face selected.


#16

Have you tried using a regular mouse?


#17

I dont have a regular mouse for my tablet PC. But the function of the button on the stylus is set to right click. Moreover, Control Click which does the same thing does not work either.


#18

Can you get the context menu to pop up when you click on anything?

Borrow an inexpensive mouse and try it to rule out the tablet/stylus button mapping.


#19

So I found a workaround Edit>Faces>Texture>Position I had to position each face individually. Couldn’t see the option to position same texture across all faces. And was trying to invert the photo texture as well. So then I export an FBX and get this disaster. I don’t know why stuff can’t just work. looks fine in su