Cathedral without textures when i try to export

Hello to all the community.

Maybe somebody can help me.

I am trying to export this model to unreal:

I can do it, but i have a problem with some textures that dissappeared. I export to other programs like 3dsmax and i am having the same problem. Lot of textures are missing. It only happens with this model. Does anybody know why or how can i fix it?

Thanks in advance.

I haven’t tried it in any other programs, but you have a lot of reversed faces (the blue ones). Reverse them first and see if that fixes it.

Thanks for your answer, i really apreciate it.

I am new with sketchup. I will try it tomorrow, to see if i can fix it. Thanks!!

Reversed faces show blue, as in above image. And most renders ignnore them, or at least don’t show a texture for them.

Are the blue-grey faces in the image the ones that don’t render properly?

Click on the Styles icon (6th from top, with blue/cyan highlight as shown here)

Click again to expand Assorted Styles, then Monochrome (the black one, third from top on the left). It has a faint border round it to show it is selected, and a tooltip pops up when your cursor is over it. (Screenshot can’t capture my cursor.)

In Desktop versions the equivalent is on the View/Face styles/Monochrome menu or the Styles toolbar(Windows) or Tool palette (Mac).

Select the blue faces (open component(s) for editing as many times as needed to see ‘raw’ faces).

Then R-click and choose Reverse faces.

If some are white and some blue in the same context, trying R-clicking on a white face and choose Orient faces.

@McGordon

How did you get the model to edit the styles? Download it from the Warehouse? If so, how did you find it? By the OPs avatar name - is it the same as the Forum? Or some other means?

Clicking on the image took me to an online Warehouse viewer, but I couldn’t see any way of editing it, only viewing.

Click at the bottom right of the image at the top of this thread to see it on the 3D warehouse. You might have to click past a message that I didn’t read first.

If you click at the bottom left you get a 3D view in this page.

After you’ve clicked to use the 3D viewer, the link to the warehouse is now on the bottom left. You just have to read what the words say as they move around.

Thanks. I learn something every day on this forum. I didn’t click around enough in the image or the viewer when it opened.

Thank you very much for your help, i did try to do it, but it is impossible for me. There are some mix textures and if you reverse, the other side goes wrong. Also if i reverse i loose the main facade texture.

If you can get all the faces white in Monochrome view, paint the back face texture with the default (should turn blue), and reapply it on the white (front face). See if that works.

Haven’t time to try myself at the moment. Sorry.

How can i do that? I am new with sketchup. Sorry for the nuisance.

Open the model. Change view to Monochrome (see above for how to in SU Free).

Double click on a component with a blue face or faces. (If you can’t select a face, you haven’t opened up the component chain down to the geometry, so double click again if you still aren’t seeing faces to select, but it’s not very likely you have nested components - one inside another).

Then do as i said earlier - R click and choose Reverse faces, or click on a white face in the same context and choose Orient faces.

Just managed to download your model.

Here’s the model after I’d double clicked on the reversed front face several times - it IS quite deeply nested - wrong assumption on my part.

R click - Reverse faces.

If you need to, re-apply the image using the Paint Bucket tool (shortcut b for paintBucket) from the Materials panel (this is what it looks like on Mac desktop SU 2020, may be different on Free - I’m not very familiar with it). The selected texture is faintly highlighted in blue. Drag that over the facade and click to paint it.


But it may just transfer the image from the back to the front face. Either way, you end up with this: the facade image on the central face.

It’s now slightly misaligned, so click once on the face and R-click and choose Texture.


(If you don’t see that option on the R click menu, make sure you have only selected one face, and no edges or other faces and try again.)

(Sorry for sporadic updates - I keep clicking Save Edit when I haven’t finished, and don’t move my mouse far enough to click on the SU window which is what I intended to click on).

Then drag the texture to position it properly.
And click Done to finish.

I know you don’t have Outliner in SU Free, but this is what it shows - the face with the central facade is nested a couple of levels deep in the model.

Does that help?

I know the SU Free interface is different but the same names for the same tools apply, and on the left you can search for them. And the R click menus are the same as on desktop.

It worked! I have to correct a lot more of textures, but this should fix the problem importing in fbx. I would tell you for sure when i finish. Thank you very much for your help. You’re amazing!