Some textures dissapearing


#1

hi hello everyone. Im using sketchup to make 3d models for a unity project, as it is much simple than blender and less time consuming.

Im using the web editor. The problem comes when I download my model and textures are not downloading!! only color based materials are showing. Does anyone know what is happening?? thanks!!


#2

What format are you download it as?


#3

thank you for your response. I’ve downloaded the offline program and now i have a different problemare nice now, but qhen i export, no matter what format, a lot of faces lose their texture, randomly apparently, and my model doesnt look nice do you know what is happening ?? thanks


#4

Maybe you could upload an example SketchUp model file that shows this problem.


#5

ok, as i corrected, faces dont get destroyted, just lose their texture. Here is an exampleSphere (1).skp (205.5 KB) when i export it as .obj or .3ds it just goes crazy.


#6

I expect it’s because many of your faces are reversed. They show as blue when you use the Monochrome face style or before you apply materials to the. You need to correct the face orientation so only white front faces are exposed.

When the face orientation is correct it should look something like this.

Of course since you didn’t fix the face orientation before painting it, you’ll need to repaint a lot of the faces.


#8

Select the wrongly oriented faces, right click on one and choose Reverse Faces.

Sometimes you can right click on a correctly oriented face and those Orient Faces but in your model, that option reversed some correctly oriented faces, too.


#9

ok, but i dont really understand, i must paint my design without changing camera angle? or is it something else?


#10

I didn’t say anything about camera angle. You need to reverse the blue faces so their white sides are out and visible. Then you need to paint those faces that you corrected because you’ve painted the wrong side of them.

If you stay on top of the face orientation as you are modeling, you wouldn’t have to go back and repaint.


#11

This topic was automatically closed after 91 days. New replies are no longer allowed.