Textures to 3DS Max

Hi

I have a Sketchup model which has textures applied to it and I want to export it to 3ds max.
The issue is that when it exports and I open it in max, the textures can be relinked but the texture coordinates don’t work.

Am I missing something or can this be done?

Thanks,
N

Does Sketchup export with texture coordinates?

SketchUp doesn’t store ‘coordinates’ so so speak for textures since SketchUp doesn’t link to them externally the way Max or even V-Ray does. Textures are embedded into the SketchUp model itself (which is why sometimes a simple model can be large in file size since it adds the material file sizes in as well). So the detaching and re-linking is what (I’m assuming here) is causing the loss of ‘coordinates.’

Maybe some out there with more experience with 3DS Max can chime with a workflow to preserve materials during export/import. For example, with V-Ray, you can ‘Pack’ your V-Ray scene which moves linked assets and materials into a sub folder, preserving paths, etc.

I’m almost certain that I have imported models from SU with the textures working fine.

Maybe you can share the model or at least screenshots for context then.

There isn’t much to see but I have attached a screen grab - SU on the right and Max on the left.

The textures are linked and applied corrcetly but, no use.

It would be worth trying different export options. You would think that 3DS would do well, but if not try Collada.

Unless you have used UV extensions there isn’t the same concept as you get with a normal texture map, but the basic materials should apply correctly.

I’ve tried 3ds, Fbx, Obj, Dae, Kmz and saving different versions of SU. The strange thing is that one of the pieces of geometry comes in with a texture on it but it’s the only bit of geometry which isn’t setup correctly! Is there a way in SU to merge the geometry or collapse it? In max it can be converted to en editable poly to merge it to one piece of geo.

Are you using the triangulate all faces option? Does any more show up if you do two sided faces?

Yes I have triangulated faces selected and selecting Two sided faces doesn’t help unfortunately

Could you reply with a small example export? It would be worth importing into Unity or other tools, to see if it’s an export from SketchUp problem, or an import to Max. A dae and fbx file would do.

The SU file is attached.Model_01.zip (13.5 MB)

Can you try importing this version and tell us what happens? I made the textures along just this one wall ‘Unique’ and dumped the rest.


Model_01_v2015.skp (4.1 MB)

It works!
What did you do? I’m not a SU user so a step by step would be appreciated.

I right-clicked on one of the faces (may have to turn hidden geometry on)…and choose ‘make unique texture.’ I did this for about 6 faces as I just wanted to see if it would work. This will replace the one texture with many images and make it an individual texture containing only what shows on that particular face. Bit tedious as you’ll have to repeat this process for all the faces the texture is applied to but better than re-mapping in 3DS Max. Good luck.

There are a few things that are odd about the model. It has 9,938 components in it, but only 191 of those are used. Most of the faces are using one texture, that is a texture map. It’s amazing that SketchUp can cope with that, but it seems that exporting seems to lose the UV mapping. BTW, the same symptoms do show in Unity, and Eric’s test worked there too.

What application was used to make the model, or at least to texture it?

I made a no components version. It doesn’t solve the main issue of losing the textures, but it’s 1/3rd the file size, and performs a lot better. I also tried Skimp on it, and got it down to 6MB, but it did lose the texturing at that point.

Here’s the no components 14 MB version.

Model_01nocomp.skp (13.3 MB)

1 Like

First I exploded model once, then I exported from SketchUp Make 2017 with TIG: OBJ Exporter plugin

Then I imported in Blender and Meshlab

Eric, Colin - thank you so much for helping me with that!!!

It works not and I would have lost a days work if you guys weren’t able to help.

Thanks again!

The model came from a third party and I have no way to contact them.

Mihai - I tried importing it into Blender but had no success although, I didn’t put it through Meshlab - thanks for your help!

I have attached the OBJ file and the Blender file to the message as well. Test them.