Private preferences.json

I am trying to isolate an extension that is giving me issues. I have removed all installed extensions, deleted the contents of the plugins folder and restarted the computer. Then I ran a repair using run as administrator. The listed extensions in the app data plugins folder are the standard installed extensions. The private preferences.json in appdata local lists all the extensions that were in the original installation. Should that file have been overwritten to remove all the extensions except the standard ones? They are still listed after a file open and save. Finally I removed SketchhUp completely, including the files left in the program files and program data. But the question still remains, should all the extensions have been removed from the private preferences.json file?

Did you remove the extensions using the Extension Manager, “Uninstall”, After running as Administrator?

Yes, that was the removal method.

And you had originally installed as Administrator?

Did you see any of the extensions in the PrivatePreferences.json (it seems like you did)?

That is the method I install all my software.

So do you now see them?

After removal of SketchUp, the file is now clean. After looking at several other threads concerning this file I have the impression it should be overwritten with a repair operation. @colin what is your take on the situation?

That’s what I would have presumed too. I’ve been manually deleting some out today and I’m not using Uninstall as I’ve had that delete extensions in folders. I want to do another Admin repair but I’m not sure if I have to backup my extensions before doing so or risk losing them.

There is an error that shows up with Scan Essentials (I believe) that shows up in the Developer Console every time SU is opened. Is that the problem one you are seeing? warning: undefining the allocator of T_DATA class swig_runtime_data

Just speculating here…I wonder if leaving zombies in the json file was intentional so that if you resurrect an extension it comes back the same as before you killed it?

That would seem reasonable. Version numbers are there along with the enabled/disabled state. Maybe that would allow someone to reinstall an extension in a disabled state (I don’t think you can install and set to disabled at the same time).

The developer console is clean when opening SketchUp.

Hmm. I just disabled Scan Essentials to get rid of the warning. That one might be a carry over… Nothing better than a clean developer console :slight_smile:

My situation gets stranger, after loading a bundle from Sketchucation. As I was sorting the new toolbars on screen, I realized that I did not need Extrude Tools from TIG. It was removed via the Ext Manager, file saved and closed then opened SketchUp. the error on opening was:
Extension Errors Report
SketchUp: 24.0.484
OS: Windows 10
Ruby: 3.2.2

Extension: [unknown]
Error: LoadError (cannot load such file – deBabelizer.rb)
<internal:C:/Program Files/SketchUp/SketchUp 2024/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb>:85:in require' <internal:C:/Program Files/SketchUp/SketchUp 2024/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb>:85:in require’
C:/Users/Dave Johnson/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/ExtrudeTools.rb:22:in `<top (required)>’

“deBabelizer.rb”: 1, is still in the Private prefs file and Extrude tools is still in the SketchUp Plugins file

When you install some of my extensions, like ‘ExtrudeTools’ they load a necessary secondary extension called ‘deBabelizer.rb’, which is a somewhat antiquated language translator…
If you have thrown that away Extrude tools will throw an error.
If it’s not in your Plugins folder then re-install the ExtrudeTools and it’ll be back when you restart SketchUp…
Clearly ExtrudeTools was NOT uninstalled by the ExtensionManager - otherwise you would not get it’s loading errors.
If you want to ‘Uninstall’ any plugin there is a manager tool in the Extensions/SketchUcation submenu to do this.
Using this method stops the plugin reloading as SketchUp starts, but offers the chance of re-installing it later [the chosen loader .RB is renamed .RBX, so then it no longer appears in the other manager dialogs - but if you want to ‘disable/enable’ a plugin (perhaps temporarily) then the manager menu item (or Toolbar button) renames .RB as .RB! and vice versa]
The SketchUcation toolset offers all of these menu items and toolbar options, and is needed for some licensing etc, so it is worthwhile installing the latest version [v4.4.0]

@TIG Thanks for the tip, I noticed the uninstall feature but did not know how it worked.

If anyone finds this thread, the outcome is a computer error. A fresh install of Windoze was the cure.