Sketchup Pro 2023 - Extension Manager not opening

Hi everyone

I have a problem, my extension manager won’t open when I press it…
Tried the toolbar menu dropdown, and the toolbar shortcut.

  • Uinstalled sketchup
  • Cleared all appdata from sketchup folder
  • Downloaded a new version
  • Run as admin
  • Installed
    … Same issue…

Tried the Ruby console thing I found here but this is the result…

Tips please ? :frowning:

When you installed did you right-click on the downloaded file and select “run as administrator”? If not do so and select the repair option.

Yes I did, and also tried after to run as admin - repair but for nothing :frowning:

From which folder? Did you delete tmpcache.dat from User/AppData/Local/SketchUp/SketchUp 2023/SketchUp?

That didn’t work…

But I found the solution… I deleted the PrivateReference.json from User/AppData/Local/SketchUp

I have cleary been confused when searching the forum for answers and tried to delete this in User/AppData/Roaming and not Local … (SharedPreferences.json is in AppData… my fault :frowning: and that’s not the same as I read in earlier posts)

Now working :smiley: Thank you so much

It really should have been a part of the “Repair Sketchup Install” that these files get deleted