Print dialog box partly empty


#1

LS, after printing succesfully to PDF once the second time the dialog box remains empty and I cannot print (to anything) anymore. On another machine I could again print the same model once but not anymore after that.

Any ideas?

Thank you in advance, best regards, Ruud.


#2

I’m having exactly the same issue! I have tried it on two different computers as well, with completely different specifications, and versions of Sketchup installed at different times. Amazed that nobody else has had this problem, or found a solution, so will be interesting to see whether anyone else has anything!


#3

Hi there,

I’m new here but not new to SU. I’m currently running SU2017Pro and I get the same blank print dialog boxes. I can’t choose any of the scales and units nor print quality pull downs. SU2016 was fine. What’s going on?

Anyone else find a solution to this?
Thanks.


#4

with every printer?
Windows restarted already?


#5

Which printer(s) are you using? Which version of the driver do you have installed? Does the problem also occur if you attempt to print to PDF?


Print to scale (1:1)
#6

Oh THANKS!!! If I change the Printer within the Print Preview or Print dialog - no change, everything is still blank. However if I change the printer in Print Setup… then go back to Print Preview or Print dialog the pull downs appear and I can select them. I guess its only the printer I am currently selected that gives me the blank pull downs (Xerox Workstation 7835i). Wow thanks, it was driving me crazy. Its our office networked printer. Its the latest driver by Xerox. It would be nice if I didn’t have to write a PDF then print it afterwards just to get a view out.


#7

download latest printer driver
write down UNC path of network printer share (i.e.: \\ServerName\PrinterName)
delete the Xerox WS 7835i printer
restart Windows
install latest driver version downloaded above preferrably w/ admin rights (“r-click > run as admin”) by connecting to the port written down above


#8

I have an opinion of Xerox printer drivers but this is a family-friendly forum so I’ll keep it to myself.


#9

Thanks for sharing this potential workaround. The other users who reported this issue were using HP printers so it’s interesting to hear that a different printer/driver also exhibits the issue.


#10

That is actually not correct, the (my) initial post reports the problem when printing to PDF.

The workaround by 2k328ci works for me too.

BrR.


#11

Hi,

I have the same problem ever since I have a new printer (HP officejetpro 7740)
Former printer was also HP, never had issues.

I tried:
reinstalling SU
Reinstalling printer drivers

Workaround by 2k328ci works but I need to do this every time again.

Did anyone found a good solution yet?

Thank you,

Dieter


#12

Not so much a solution as another workaround, I stopped using print altogether and nowadays use Export => 2D Graphic. If necessary I print the resulting images.

BrR.


#13

Curious to know if anyone who experienced the problem was using Parallel Projection or Two-Point Perspective (camera) views.


#14

No, neither of those.

BrR.


#15

All,

We believe we have root-caused this issue. It appears to be related to Win 10 systems where the Microsoft Print to PDF driver is set to the default.

If you’ve encountered this issue, could you see if your default printer is the Microsoft PDF driver?

In Win 10, you can find this in Settings > Devices > Printers & scanners.

First, un-check Let Windows manage my default printer.

When that is un-checked, the default printer will be displayed.

We have found that changing the default printer to a different one fixes the empty print dialog box. You can change the default printer by clicking next to another device, and selecting Manage.

Then click on Set as default, and close the window.

Relaunch SketchUp, select File > Print, and you should see the correct values.


Print to scale blank
Not printing at all
No scale-units to choose from when trying to print to scale
#16

Thank you mchandler, seems to be working for me.

BrR.


#17

I have exactly the problem described here. Windows print to PDF worked the first time, very nicely. But now the print preview and/or print dialog boxes are empty, if I have Windows PDF selected. Selecting other printers works OK. I have tried setting the printers through the windows control panel. No help.

This thread was short and intense in January. Anybody have any experience since? Is there a workaround to getting Sketchup to print using “Microsoft Print to PDF”? Thanks for any feedback.


#18

Are you trying to print from Sketchup or Layout/? Possibly share the file so someone else can try to duplicate the issue. Also what version of Windoze do you have?


#19

I am trying to print from Sketchup Pro 2018. I have a new (3 mos old), clean computer with Windows 10 Pro.

I launch Sketchup. My default template has only “Stacy” in it. To make this easy, I try to print Stacy. I have turned off the “Let Windows manage my default printer” as suggested above.

I go to “Print Setup…”, and select my network printer. I go to “Print Preview…” Dialog box is fine. I get a good preview of Stacy.

I go back to “Print Setup…” and select “Microsoft Print to PDF”. Now I go to “Print Preview…” The dialog box is full of empty fields, as reported above. No Scale. No Page Size. No radio button set on current view or scenes.

I go back to “Print Setup…” and select “Microsoft XPS Document Writer”. Now I go to “Print Preview…”. The dialog box is now good, and filled out as expected.

One more time back to “Print Setup…” and “Microsoft Print to PDF”. Then “Print Preview…”. Dialog box has empty fields again.

It seems there is something buggy in the interface to “Microsoft Print to PDF”. Printing directly to PDF is a very useful function. To get by, I downloaded a generic PDF printer, which worked fine. It is a shame that Sketchup does not work directly with the native Windows 10 PDF generator. (As mentioned earlier, I am trying to avoid bloating my machine with too many add ons)

The best clue in this whole chain is the very first blog entry from RuudM. I experienced EXACTLY what he described. “Microsoft Print to PDF” worked exactly one time for me, the first time I tried it. I created a PDF with four scenes. I thought that was really great. The second and subsequent times the dialog box was corrupted. I have rebooted my machine once, no improvement.

If you try to duplicate this, see if you can do a “Microsoft Print to PDF” more than 1 time, switching to another printer between tries.

Tschuss


#20

I don’t have that issue, that is why I am asking about the exact windoze version. Type winver in the search box, it should return the version, 17…, 18…