Poor line quality with new graphics engine?

Is anyone experiencing low quality jagged lines with new graphics engine? As far as I can see, I have the settings correct…or not?

2 Likes

Can you make a screenshot using the old API?

Just to see, have you tried lower anti alias settings?

Can concur that line quality in the new graphics engine looks very poor. Aliasing settings do not help.

Anti aliasing settings also do not make a difference on mine, other than worse when lower as expected. Quality back to great when switching to classic graphics engine. I just hope this isn’t a case of ‘function over form’.

Comparison using classic engin


e. Much less subtle on actual monitor!

1 Like

I have Nvidia Geforce RTX 3060 and have the same problems with the new graphics engine at max anti aliasing 8x.

The new graphics engine at max anti aliasing is not as crisp as the classic one at 8x (could go to 16x with classic)

Hopefully you can see the difference (captured with faststone using Repeat last capture.

New Graphics engine

image

Classic Graphics engine

image

1 Like

Yup, same problem on my PC desktop and laptop. Edges are noticeably thicker and more jagged. Tried to adjust with some NVidia settings but this needs some fine tuning, I believe.

1 Like

I also noticed this problem.

1 Like

I can’t understand why this thread has yet to be addressed by a team member? What good is a version update if the quality is worse than its predecessor?

My Windows PC has an RTX2060 and I think I’m a few updates behind the current GeForce Experience driver.

For me I would not say the line quality is worse – the lines in 2024 with the new graphics engine are a slightly more “bold” than in 2023.

I’m on 8x anti aliasing.

I’m not bothered by it in SketchUp – if it’s affecting viewports in Layout, I haven’t noticed it (yet).

I don’t know if it makes a difference – have you set SketchUp and Layout to use the GPU in Windows Settings > System > Display > Graphics?

1 Like

I’d say that line quality is related to how your graphics are displayed. I have multiple monitors, 7 in this specific setup, some mirrored, and some monitors show clean lines and others are less attractive.
Just quietly, it seems future answers have ignored present suggestions.

1 Like

On my 1440p monitor and 1080p monitor using a RTX 4070 Ti, on an AMD Ryzen 5900X, I don’t seem to be experiencing these issues:

(Did a quick n’ dirty totally inaccurate mock-up of an example earlier to see how it looked on my side)

All things considered the edges look pretty good? Have you tried going into your Nvidia Control Panel settings or Windows graphic settings and toggling between performance and quality modes to see if that makes any change?

live view to Box’s HQ

5 Likes
Way off topic

Well actually I live on a boat, I have 3 monitors in my ‘office’ the only part of the boat I can effectively heat or cool. I have 2 monitors in my workshop area suspended from sliding door tracks so I can move them about as needed and the last 2 are upstairs in my ‘gym’ a treadmill and rowing machine area to stay somewhat healthy. I can be on my treadmill and watch my 3d printer and laser cutter/engraver via web cams while answering forum questions and watching a movie, and all voice activated. I have to struggle with only 2 screens in my land based workshop 30 seconds walk away at the end of the dock tho.

2 Likes

I’m still on 2023 until I finish the project I’m working on. I don’t care about the lines being bold on sketchup if they’re displayed well on LayOut, does anyone know if the line quality on layout is affected with the new graphics engine?

Nope – vector and hybrid are good for me.

I don’t do raster very much so can’t comment

Good to know, I use raster just while working but I export as vector always as well.

Response to off topic

I feel like your life story is AI-generated that used the prompts “high-tech Jimmy Buffet”. :laughing:

Personally, I think the last pic above ‘does’ show the jagged edge issue! The lines when new engine is off are perfect & pin sharp. I’m using RTX 3060 so surely not a problem with graphics potential? If there is a specific way to set up… I’d love to know!